MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000454v2.0 Release (Closed)[All Projects] Generalpublic2010-05-31 12:202010-06-21 22:11
Reporteropto 
Assigned Tocaseydk 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Versionv2.0.0 
Summary0000454: can't display user related task priority for single user, can't reset the same to normal
Descriptionsee http://forums.web2project.net/viewtopic.php?t=2152 [^] both for description and patch
TagsNo tags attached.
Attached Fileszip file icon tasksperuser_sub.zip [^] (7,120 bytes) 1969-12-31 17:00

- Relationships

-  Notes
(0000923)
opto (developer)
2010-05-31 16:55

currently, there is no way to intentionally display all users on this page.
This can be changed the following way:

in reading the POST for $log_userfilter, use default 0

before the arrayselect for the displayed user list is called,
enter '0' => 'All users' to the array containing the user names.
If I remember right from what I did 6 weeks ago, this allows to select 'all users'.

Also, in my case, where the display of all users takes 100sec, I just use another default than 0 for my installation
(0000925)
caseydk (administrator)
2010-05-31 21:29

Resolved differently than described but the same result in r1129.
(0000932)
opto (developer)
2010-06-01 08:46
edited on: 2010-06-01 08:57

sorry, the forum post also had another issue:

can't reset the user task priority to normal because there is an onchange event for the drop down list, if this is preset with normal in default display, it cannot be thrown by setting to normal.

In the current version, part of my proposal is there, but not all:
I see select user prio, high, normal, but no low.

Setting to high works, resetting to low does not.

if you change
$taskPriority[999]=$AppUI->_('Select User Priority');

and -1 to 999 in
    $tmpuser .= '<td align="center">' . arraySelect($taskPriority, 'task_priority', 'onchange="javascript:chPriority(' . $user_id . ');" size="1" class="text" title="' . $AppUI->_('Change Priority of selected Tasks') . '"', -1, true);

this is resolved.
beware, there is another location of this for the orphans, where it also needs to be changed.


No low in dropdown:
I intentionally set the set user priority to 999, because the priorities are centered around 0: low is -1 (at least in my dP conversion - is that nonstandard now?). And nobody (hopefully) will have +- 999 priority levels
So currently, the select ... at [-1] overwrites the low priority.
Klaus

(0000938)
caseydk (administrator)
2010-06-02 20:50

Thanks for the tips.
Resolved in r1131.

- Issue History
Date Modified Username Field Change
2010-05-31 12:20 opto New Issue
2010-05-31 12:20 opto File Added: tasksperuser_sub.zip
2010-05-31 12:45 caseydk Status new => assigned
2010-05-31 12:45 caseydk Assigned To => caseydk
2010-05-31 16:55 opto Note Added: 0000923
2010-05-31 21:29 caseydk Note Added: 0000925
2010-05-31 21:29 caseydk Status assigned => resolved
2010-05-31 21:29 caseydk Resolution open => fixed
2010-06-01 08:46 opto Note Added: 0000932
2010-06-01 08:46 opto Status resolved => feedback
2010-06-01 08:46 opto Resolution fixed => reopened
2010-06-01 08:50 opto Note Added: 0000933
2010-06-01 08:50 opto Note Edited: 0000933
2010-06-01 08:51 opto Note Deleted: 0000933
2010-06-01 08:51 opto Note Edited: 0000932
2010-06-01 08:57 opto Note Edited: 0000932
2010-06-02 20:50 caseydk Note Added: 0000938
2010-06-02 20:50 caseydk Status feedback => resolved
2010-06-02 20:50 caseydk Resolution reopened => fixed
2010-06-21 22:11 caseydk Status resolved => closed
2010-06-21 22:11 caseydk Fixed in Version => v2.0


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker