MantisBT - v3.4 Release (Current)
View Issue Details
0001592v3.4 Release (Current)Project Designerpublic2014-08-05 13:372019-01-03 12:53
Reporteropto 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0001592: can't set user priority (admin account in test installation)
Descriptionwe just solved that, what happened?
TagsNo tags attached.
Attached Filespng Screen Shot 2014-08-16 at 10.01.52 PM.png (88,829) 1969-12-31 16:00
https://bugs.web2project.net/file_download.php?file_id=434&type=bug
png

Notes
(0003575)
caseydk   
2014-08-06 14:47   
I just tested against my master and I'm not seeing any issues. I tested the select all and individually selecting items.
(0003582)
opto   
2014-08-07 04:14   
I still can't set, nothing happens

to be sure that I am assigned, I created a task in projectdesigner and tried to set UP for that.

Maybe there is a bug in adding tasks in projectdesigner which then triggers this behaviour?

3.2 truely can do this.
(0003583)
opto   
2014-08-07 04:15   
(Last edited: 2014-08-07 10:23)
maybe UP is set but not diplayed?

(0003584)
opto   
2014-08-07 13:28   
(Last edited: 2014-08-07 13:30)
I just doublechecked the db. UP is correctly set.

But projectdesigner does not show UP, only a - sign for all tasks.
Doesn't that mean that the userid is wrong in the sql?

P shows either arrow up, down or space, but not - sign

(in FF)


for example, is correctly shown in my tasks

(0003588)
opto   
2014-08-13 09:16   
why was this assigned to me? I think I fixed it already in 1530.


actually, it does set, but not display.

see email or:


do you really see user priorities in your projectdesigner?

if I understand the new code correctly, vw_projecttasks creates the task view, which then is actually done in gettasktree which collects the tasks.

This, just as pre bugfix 1530, does not get any user priority from the db, so it is clear that only a - is displayed - just as before my bugfix.

same for tasks

todo shows UP but gets tasks from one of the old functions.

Klaus

(0003624)
caseydk   
2014-08-16 20:04   
You are correct that this is working as expected. I've attached a screencap from my project designer.
(0003666)
opto   
2014-10-09 04:31   
(Last edited: 2014-10-09 04:33)
sorry to say, but it is not fixed for wampserver and php 5.3 (I think).

Your screenshot further up actually shows Priority, not user priority. UP would be the - sign next to it.
As I wrote further up, the new function does not get UP from the db, so it cannot display, unless you changed that.

see note (0003588) (ca. 2 notes up) for fix

Klaus

(0003700)
caseydk   
2014-10-19 11:59   
I've been digging on this one and added the field to the query. Fixed on master here:
https://github.com/web2project/web2project/commit/3f49f6c7a663ef4bd638b1a16359af096bb8e491

That said, I'm starting to not like User Priority at all.. because if you have three users who's priority do you show? How do you designate which is for which person?
(0003701)
opto   
2014-10-19 13:42   
to comment your last note:

projectdesigner shows my (=logged in) user priority or a minus sign for not applicable. Also, it allows to set my UP (only mine), and I think the text on the edit box is clear about that.

Somewhere in tasks, I can show and edit the UP for all users.
Each user's todo shows his/her individual UP.

This all makes total sense, because:

a low priority task gets high priority for the assigned user when it comes up for him to do it. Also, I can use UP to guide employees what to do first.

Even if the task has high UP fir the user doing it, its relative priority for the project context is not changed. In view of all other tasks, it is still low priority. So we wouldn't want to use priority for this.
But not for the team member actually working on it, for him (only), it has high priority at a certain point in time (otherwise he would never do it).
(0003917)
caseydk   
2019-01-03 12:53   
In the 31 Dec 2018 release: http://docs.web2project.net/release-notes/3.4.html

Issue History
2014-08-05 13:37optoNew Issue
2014-08-06 14:47caseydkNote Added: 0003575
2014-08-06 14:47caseydkAssigned To => opto
2014-08-06 14:47caseydkStatusnew => feedback
2014-08-07 04:14optoNote Added: 0003582
2014-08-07 04:14optoStatusfeedback => assigned
2014-08-07 04:15optoNote Added: 0003583
2014-08-07 10:23optoNote Edited: 0003583bug_revision_view_page.php?bugnote_id=3583#r87
2014-08-07 13:28optoNote Added: 0003584
2014-08-07 13:30optoNote Edited: 0003584bug_revision_view_page.php?bugnote_id=3584#r89
2014-08-13 09:15optoAssigned Toopto => caseydk
2014-08-13 09:16optoNote Added: 0003588
2014-08-13 09:16optoNote Edited: 0003588bug_revision_view_page.php?bugnote_id=3588#r97
2014-08-16 20:02caseydkFile Added: Screen Shot 2014-08-16 at 10.01.52 PM.png
2014-08-16 20:04caseydkNote Added: 0003624
2014-08-16 20:04caseydkStatusassigned => resolved
2014-08-16 20:04caseydkFixed in Version => 3.2
2014-08-16 20:04caseydkResolutionopen => no change required
2014-09-02 13:23caseydkFixed in Version3.2 => 4.0
2014-10-08 09:20caseydkProjectv3.2 Release => v3.3 Release
2014-10-08 09:21caseydkTarget Version => 3.3
2014-10-08 09:21caseydkFixed in Version4.0 => 3.3
2014-10-08 09:22caseydkStatusresolved => closed
2014-10-09 04:31optoNote Added: 0003666
2014-10-09 04:31optoStatusclosed => feedback
2014-10-09 04:31optoResolutionno change required => reopened
2014-10-09 04:33optoNote Edited: 0003666bug_revision_view_page.php?bugnote_id=3666#r107
2014-10-11 20:18caseydkStatusfeedback => assigned
2014-10-19 11:59caseydkNote Added: 0003700
2014-10-19 11:59caseydkStatusassigned => resolved
2014-10-19 11:59caseydkResolutionreopened => fixed
2014-10-19 13:42optoNote Added: 0003701
2014-10-19 13:42optoStatusresolved => feedback
2014-10-19 13:42optoResolutionfixed => reopened
2014-11-21 21:38caseydkStatusfeedback => resolved
2014-11-21 21:38caseydkResolutionreopened => fixed
2016-12-26 23:37caseydkProjectv3.3 Release => v3.4 Release (Current)
2019-01-03 12:53caseydkNote Added: 0003917
2019-01-03 12:53caseydkStatusresolved => closed