MantisBT - v3.3 Release
View Issue Details
0001625v3.3 ReleaseFilespublic2014-09-29 07:472014-10-08 09:21
Reporterchdrsto 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSDebianOS VersionTesting
Product Version 
Target Version3.3Fixed in Version3.3 
Summary0001625: Unable to upload documents of files
DescriptionI'm running fresh installed W2P 3.2 on a Debian Testing system. It's an Apache 2.4.10 with PHP 5.6.0 / MySQL 5.5.39 installed.

On this (fresh) installation it is not possible to use file module to upload any file nor document.

By pressing the save button I get a blank and empty page without having the file uploaded. I've also created a folder named 0 (zero) and checked the folder pemissions on file system level. All seems to be OK.

On log file i get some PHP warings (see attachment)
Steps To Reproduce1) Open upload file module
2) Attach a file (on Project or not)
3) Press save button
Additional InformationIve also requested information / support on W2P Support forum without success.
http://support.web2project.net/questions/1563/unable-to-upload-documents-or-files.html
TagsNo tags attached.
Attached Filestxt LOG.txt (978) 1969-12-31 16:00
https://bugs.web2project.net/file_download.php?file_id=436&type=bug

Notes
(0003664)
opto   
2014-10-06 09:02   
see forums:
from burnspot




I THINK I SOLVED IT (maybe). In my download from the W2P site, the "Filesystem.class.php" file appears like this: FileSystem.class.php....the "S" in system is capitalized. The error message refers to the file as having only the "F" capitalized. Once I renamed the file with only the capital "F", it worked. So far, I've tested with a file attached to a task and one that's not attached to anything...works fine.
(0003665)
caseydk   
2014-10-06 09:36   
Fixed in development:
https://github.com/web2project/web2project/commit/653c7873cd1a0148240eaf857a258068d921969c

Issue History
2014-09-29 07:47chdrstoNew Issue
2014-09-29 07:47chdrstoFile Added: LOG.txt
2014-10-06 09:02optoNote Added: 0003664
2014-10-06 09:36caseydkNote Added: 0003665
2014-10-06 09:36caseydkStatusnew => resolved
2014-10-06 09:36caseydkFixed in Version => 3.2
2014-10-06 09:36caseydkResolutionopen => fixed
2014-10-06 09:36caseydkAssigned To => caseydk
2014-10-08 09:20caseydkProjectv3.2 Release => v3.3 Release
2014-10-08 09:21caseydkTarget Version => 3.3
2014-10-08 09:21caseydkFixed in Version3.2 => 3.3
2014-10-08 09:21caseydkStatusresolved => closed