MantisBT - v2.0 Release (Closed)
View Issue Details
0000486v2.0 Release (Closed)[All Projects] Generalpublic2010-06-13 06:242010-06-21 21:05
Reporterdavid 
Assigned Tocaseydk 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionv2.0.0 
Target VersionFixed in Versionv2.0.0 
Summary0000486: Cannot add tasks to projects
DescriptionSuccessfully installed June 8 nightly.
Created a project.
Attempted to create a task, task is not added.
Navigating back to the project, drilldown button saying that there is a multi-project structure (even though I had only created a single project), and opening the drilldown throws a php error.
Screenshots attached.
Tried with a second project, same problem.
TagsNo tags attached.
Attached Filespng TaskCreateFail.png (559,992) 1969-12-31 16:00
https://bugs.web2project.net/file_download.php?file_id=90&type=bug
zip w2pone.zip (105,110) 1969-12-31 16:00
https://bugs.web2project.net/file_download.php?file_id=91&type=bug

Notes
(0001008)
caseydk   
2010-06-13 16:40   
I can't reproduce this one on galleon, Firefox (Ubuntu or Win7), or IE8..

What version of IE are you using? Are you using any popup blockers?
(0001012)
david   
2010-06-14 07:01   
IE8.0.6001, pop-up blocker off.

I just downloaded the most recent w2p nightly, configured it with a new db schema, and still cannot add tasks.

I will add the database file, in case that would help diagnose the problem.
(0001017)
caseydk   
2010-06-14 10:51   
Are you getting any sort of error messages whatsoever? Javascript? PHP error log? Apache? Has it ever worked for you? Have previous versions worked for you?
(0001019)
david   
2010-06-14 11:15   
The only error that appeared in the browser was the seemingly unrelated error about the project being part of a multi-project structure -- even though it was not part of a multi-project structure:
"Warning: Invalid argument supplied foreach() in C:\Program Files\Apache Software Foundation\Apache 2.2\htdocs\web2project\modules\vw_sub+projects.php on line 31"

I checked the Apache error.log, and there is no error.

I checked the database, and there was no task added.

I'm turning php error log on now.

I have never been able to add a task.
(0001021)
david   
2010-06-14 11:48   
I turned on PHP logging, and no errors were logged while trying to create and save a task. Adding tasks works neither in the classic interface nor in the project designer.
(0001023)
caseydk   
2010-06-14 17:38   
Is the path really described this?

C:\Program Files\Apache Software Foundation\Apache 2.2\htdocs\web2project\modules\vw_sub+projects.php

There shouldn't be a + sign in there.. and even more importantly, the path is completely wrong as there should be a module name in there. It should look something like this:

C:\Program Files\Apache Software Foundation\Apache 2.2\htdocs\web2project\modules\projects\vw_sub_projects.php
(0001027)
david   
2010-06-15 02:14   
Take a look at the screenshot that I attached when I reported the bug - the error is shown in both the top and bottom panes of that file, right where the drill-down to show a project as being part of a multi-project structure.
(0001029)
david   
2010-06-15 03:01   
If you would be interested, I could demonstrate the problem using gotomeeting?
(0001031)
caseydk   
2010-06-15 05:09   
Ah thanks. Sure. I'm east coast US-based, so if you have time this afternoon or late this evening, I'd love to see the problem.

Otherwise, since no one else is running into the problem, this will have to be closed.
(0001034)
david   
2010-06-15 06:29   
Excellent, I'm ready whenever you are - I'm on the East Coast as well.
(0001053)
caseydk   
2010-06-16 06:53   
Resolved in r1187 - http://web2project.svn.sourceforge.net/viewvc/web2project?revision=1187&view=revisio

Issue History
2010-06-13 06:24davidNew Issue
2010-06-13 06:24davidFile Added: TaskCreateFail.png
2010-06-13 16:40caseydkNote Added: 0001008
2010-06-13 16:40caseydkStatusnew => feedback
2010-06-14 07:01davidNote Added: 0001012
2010-06-14 07:02davidFile Added: w2pone.zip
2010-06-14 10:51caseydkNote Added: 0001017
2010-06-14 11:15davidNote Added: 0001019
2010-06-14 11:48davidNote Added: 0001021
2010-06-14 17:38caseydkNote Added: 0001023
2010-06-15 02:14davidNote Added: 0001027
2010-06-15 03:01davidNote Added: 0001029
2010-06-15 05:09caseydkNote Added: 0001031
2010-06-15 06:29davidNote Added: 0001034
2010-06-16 06:53caseydkNote Added: 0001053
2010-06-16 06:53caseydkStatusfeedback => resolved
2010-06-16 06:53caseydkResolutionopen => fixed
2010-06-16 06:53caseydkAssigned To => caseydk
2010-06-21 21:05caseydkStatusresolved => closed
2010-06-21 21:05caseydkFixed in Version => v2.0