MantisBT - v2.4 Release (Closed)
View Issue Details
0000795v2.4 Release (Closed)[All Projects] Generalpublic2011-05-05 02:402011-08-16 23:38
Reportergeorgils 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version2.4 
Summary0000795: Links not visible
DescriptionVer 2.3.1.
1. I create a link and assign it to a project, but to no task
2. I create another link in the same project, but assign it to a task
3. Both links are not displayed in the View Project's "Links" tab. They are not displayed anywhere else within the project. The only place they are available from is the "Links" menu, where also seems to be a bug:
  - they are not seen in the "All links" tab
  - they are only seen in the category tab (the cat they belong to, "Unknown" in my particular case")
  - there is no number of links in the tabs' names, so one has no idea if there are *any* links in any category. He has to click thru all available link categories' tabs just to locate the presence of a certain link, and there may be tens of categories.

This makes them extremely difficult to find, let alone this may easily mislead the user to thinking there are no links attached to a project (or to a specific task within a project) when he sees no indication of their presence whatsoever within the scope of a project. The menu "Links" is for general purposes and it is not the expected behaviour to look for your project's links there instead of in the specific project's "Links" tab.
Additional InformationWhen reached from the menu "Links" -> tab "Unknown" (the only possible place), after clicking on the link of the project name, the links are visible in the project's "Links" tab. But if you change to the "Tasks" or whatever other tab and then click the "Links" tab again - they are gone.
TagsNo tags attached.
Attached Files

Notes
(0001900)
georgils   
2011-05-05 08:21   
And another issue: say we are in "View Project". We want to add a new link to the project, so we click the Links tab, then "new link", then "submit". The next screen takes us in the middle of nowhere and going back to your project involves displaying the projects list and selecting the project you were currently working. Although this is not quite related to the bug, it's rather more a design issue I think...
(0001902)
caseydk   
2011-05-06 14:12   
There was a tab filter being applied incorrectly, resolved in r1878;
Your comment relates to issue 0000432;

Issue History
2011-05-05 02:40georgilsNew Issue
2011-05-05 08:21georgilsNote Added: 0001900
2011-05-06 14:12caseydkNote Added: 0001902
2011-05-06 14:12caseydkStatusnew => resolved
2011-05-06 14:12caseydkResolutionopen => fixed
2011-05-06 14:12caseydkAssigned To => caseydk
2011-05-21 22:21caseydkProjectv2.3 Release (Closed) => v2.4 Release (Closed)
2011-08-16 23:38caseydkStatusresolved => closed
2011-08-16 23:38caseydkFixed in Version => 2.4