Anonymous Login
2019-10-16 12:35 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001000v3.0 Release[All Projects] Generalpublic2013-08-28 11:23
Reporterpkonin 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.0 
Summary0001000: Issues with Task Dates with Dependencies
DescriptionI created two tasks, task one started on 11/2 at 9am and ended on 11/4 at 5pm. I then created a second task, start date dependent on the end of task one, with a duration of 4 days. When submitting the second task, the project view shows it as starting on 11/7 at 9am and ending at 1pm. Duration is still showing 4 days. (top image)

After correcting the start and end time of task two, I calculated the end date based on the duration. I submitted the task, and all was as it should be. Then I changed the start date of the first task to 11/2 at 9am, and task two changed to a start date of 11/9 at 4am and an end date of 11/14 at 8am. (bottom image)
Additional InformationI have tried this on 2.4 as well as 3.0 and have had the same type of issue. I have had the same results with the ProjectDesigner module, and I've tried clearing the browser cache, and I've used both Firefox and Chrome. Currently, working hours are 9-5, 8 hour workday, calendar start and end are 9 and 18.
TagsNo tags attached.
Attached Files

-Relationships
has duplicate 0000999closedcaseydk Pending Requests Task Dependancy Dates Not Working Right in 2.4 & SVN 
has duplicate 0001033closedcaseydk v3.0 Release Dependency Updates = Screwed! 
+Relationships

-Notes

~0002319

caseydk (administrator)

I *think* this is working exactly as described, just not as you expect.

It's helpful to remember that the system schedules things based on *working* hours, not necessarily on clock hours.

So when you have Task One (11/2 9am -> 11/4 5pm) & Task Two (4 days, starting immediately after One), most likely, the system saw that your work week ends at 5pm on Friday. Therefore, it would move it to first thing on your next working day... which would be 9am on Monday the 7th.

I don't know the cause of your second issue, but I just applied a major update to the dependencies which resolved about six oddities.. most likely that resolved this one too.

Please try a test upgrade (using a backup of your database, not production) and let me know how your tests go.

Thanks!

~0002325

caseydk (administrator)

Resolved in r2209 along with a number of other issues

~0002335

pkonin (reporter)

I updated to the latest nightly snapshot and am still having the same issues. I've attached an image of just the problem area. The second task is supposed to begin when the first ends, which it does. However, the end of the second task doesn't fit with its duration. I think what might be happening is that the duration of the second is calculated using the days as hours.

~0002336

pkonin (reporter)

I just tried it again, and the start date of the second task was not as expected. It starts the following day, but at 4am. Image attached as tasks error2.

~0002540

chris_brooks (reporter)

I can confirm this is still happening with 3.0.0-pre. it does NOT happen with the 2.4 demo on the web site.

pkonin is right that the second task duration is counted as hours instead of days. See attached file webproject_issue1000.png

If you edit the task and click on the calculate duration it updates the end date properly.

~0002627

caseydk (administrator)

Resolved: https://github.com/caseysoftware/web2project/pull/130

Please note that this solution is *only* available in the v3.0-pre development and can't be applied to any version earlier (eg 2.4, 2.3, etc).
+Notes

-Issue History
Date Modified Username Field Change
2011-11-01 12:07 pkonin New Issue
2011-11-01 12:07 pkonin File Added: tasks error1.jpg
2011-11-24 22:39 caseydk Relationship added has duplicate 0000999
2011-11-25 10:56 caseydk Note Added: 0002319
2011-11-25 10:56 caseydk Status new => feedback
2011-11-26 22:35 caseydk Note Added: 0002325
2011-11-26 22:35 caseydk Status feedback => resolved
2011-11-26 22:35 caseydk Resolution open => fixed
2011-11-26 22:35 caseydk Assigned To => caseydk
2011-12-01 10:41 pkonin Note Added: 0002335
2011-12-01 10:41 pkonin Status resolved => feedback
2011-12-01 10:41 pkonin Resolution fixed => reopened
2011-12-01 10:41 pkonin File Added: tasks error.jpg
2011-12-01 10:44 pkonin Note Added: 0002336
2011-12-01 10:45 pkonin File Added: task error2.jpg
2011-12-23 09:19 caseydk Relationship added has duplicate 0001033
2012-05-29 18:59 chris_brooks Note Added: 0002540
2012-05-29 19:00 chris_brooks File Added: web2project_issue1000.png
2012-08-07 21:05 caseydk Note Added: 0002627
2012-08-07 21:05 caseydk Status feedback => resolved
2012-08-07 21:05 caseydk Resolution reopened => fixed
2013-08-28 11:14 caseydk Fixed in Version => 3.0.0
2013-08-28 11:23 caseydk Status resolved => closed
+Issue History