Anonymous Login
2019-10-20 11:47 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001022v3.0 Release[All Projects] Generalpublic2013-08-28 11:22
ReporterTimK 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.0 
Summary0001022: Wrong start date when checking "Set task start date based on dependency" (timezone related?)
DescriptionMy System has a default timezone of UTC+1 (Europe/Berlin), all users are in that timezone, too.

When I create a task depending on another and let the system chose the start date, it starts an hour early. E.g.:

Task A : 11/30/2011 08:00 to 11/30/2011 10:00
Task B : 11/30/2011 09:00 to 11/30/2011 11:00
Additional InformationI was suspecting the system to fetch the end date of A out of the DB and convert it to UTC a second time, but this is of course a wild guess.

My installation behaves as expected when I set system and user timezone to Europe/London (no UTC offset), It shows the same error when I set system to UTC and user to utc+1
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0002509

Korkonius (reporter)

Hi!
I attempted to fix this in this pull request:
https://github.com/caseysoftware/web2project/pull/90

Unfortunately my brain failed me today when i attempted to verify if the issue was gone. If you are still around could you test the patch and see if it helps?

Best Regards,
Eirik

~0002510

TimK (reporter)

Hi Eirik,

yes I'm still around and I'm really thankful for your reply an the patch, which seems to be working. My task now starts on it's predecessor's end instead an hour eary.

Unfortunately, everything is displayed an hour early in the tasks overviews now. When I enter a task lasting from 9 to 17, it will be shown with 8 and 16 as start and end time.

I can not rule out the possibility of this behaviour having a different origin: i stopped using w2p because of the bug and had to reanimate and update it for testing your patch. There might have been other things happening, too.

regards
Tim

~0002511

Korkonius (reporter)

Tanks for a quick reply!

I am looking into this, and unfortunately a lot of the tasks system seem not to care about time zones... Also the tasks module is a bit messy so finding all the values, or where to edit them is not very easy...

I've added a commit to the previously mentioned branch where formatting should depend on the users timezone instead of using raw database values...

~0002536

caseydk (administrator)

Fixed as described with one tweak:

Original: https://github.com/caseysoftware/web2project/pull/90
Additional Tweak: https://github.com/caseysoftware/web2project/commit/8cebcb6f030f492eb6bb53b61aed7456f41526a5
+Notes

-Issue History
Date Modified Username Field Change
2011-11-29 22:40 TimK New Issue
2012-04-27 03:53 Korkonius Note Added: 0002509
2012-04-27 05:21 TimK Note Added: 0002510
2012-04-27 05:52 Korkonius Note Added: 0002511
2012-05-27 17:31 caseydk Note Added: 0002536
2012-05-27 17:31 caseydk Status new => resolved
2012-05-27 17:31 caseydk Resolution open => fixed
2012-05-27 17:31 caseydk Assigned To => caseydk
2013-08-28 11:14 caseydk Fixed in Version => 3.0.0
2013-08-28 11:22 caseydk Status resolved => closed
+Issue History