Anonymous Login
2019-11-21 10:16 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001064v3.0 Release[All Projects] Generalpublic2013-08-28 11:20
Reporterrobertbasic 
Assigned Tocaseydk 
PriorityhighSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.0 
Summary0001064: Adding new tasks
DescriptionNeed to turn up error reporting to notice these notices :)

After "breaking" the CTask::store method into CTask::store and CTask::hook_postStore, some of the variables are defined only in CTask::store whereas in CTask::hook_postStore they are left uninitialized leading to notices all over the place.
Additional InformationIn CTask::hook_postStore the 2 variables are "$importing_tasks" and "$oTsk". Given that these 2 variables are playing a role in updating the dynamics, this bug might be related to 0000990 http://bugs.web2project.net/view.php?id=990
TagsNo tags attached.
Attached Files

-Relationships
related to 0000990closedcaseydk Importing tasks when source has dynamic tasks causes dependency issues. 
+Relationships

-Notes

~0002501

Korkonius (reporter)

I submitted a pull request on this one...

Unfortunately since I had issues recreating the original issue I need some help verifying that the fix does indeed fix this bug.

Please see: https://github.com/caseysoftware/web2project/pull/88

~0002503

robertbasic (developer)

Will give it a spin once I get to it.

Thanks!

~0002521

caseydk (administrator)

Resolved as described in r2453
+Notes

-Issue History
Date Modified Username Field Change
2012-02-19 01:07 robertbasic New Issue
2012-02-19 01:07 robertbasic Relationship added related to 0000990
2012-04-22 22:09 Korkonius Note Added: 0002501
2012-04-23 00:06 robertbasic Note Added: 0002503
2012-05-16 17:19 caseydk Note Added: 0002521
2012-05-16 17:19 caseydk Status new => resolved
2012-05-16 17:19 caseydk Resolution open => fixed
2012-05-16 17:19 caseydk Assigned To => caseydk
2013-08-28 11:14 caseydk Fixed in Version => 3.0.0
2013-08-28 11:20 caseydk Status resolved => closed
+Issue History