Anonymous Login
2019-08-19 02:56 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001069v3.0 Release[All Projects] Generalpublic2013-08-28 11:19
Reportera17s 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.0 
Summary0001069: User unable to register online
DescriptionThe web2Project has feature for users to register or sign in from the index page. However, if one attempts to register as a new user, a fatal Server Internal Error is thrown.
Additional InformationThe error message from a local install on Windows (running Zend AMP server stack) and on shared Linux server is shown below:

Windows:

Fatal error: Call to a member function getLibraryClass() on a non-object in C:\ZEND\Apache2\htdocs\web2project\do_user_aed.php on line 10

Linux:
0
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, cgiadmin@yourhostingaccount.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

A look at the index.php shows a Session handler initialized within a block and used later on the script. It may be out of scope or not initialized at all when the script for adding new user is called.
TagsNo tags attached.
Attached Files

-Relationships
related to 0001073closedcaseydk external user is only setup as contact not as user 
+Relationships

-Notes

~0002407

a17s (reporter)

If the Session object is initialized in the script managing the user registration, the error is removed

~0002408

robertbasic (developer)

Could you please try this with a dev version? You can get it here: https://github.com/caseysoftware/web2project/downloads

Thanks!

~0002413

a17s (reporter)

Fixed the bug on registration of new users. The web2Project 2.4 edition uses session and the default application user object is not initialized in the script registering the user. The 3.0 release has this fixed but also generate the same issue as the database field contacts_owner is an unsigned int while the value -1 is being assigned. This causes the failed insert command on the database level. Setting the field to sign int resolves the bug in 3.0 pre. For 2.4 set the field to sign int and initialize the session user object. Thanks Casey!

~0002421

robertbasic (developer)

Where are you seeing this -1 exactly?

There are notices being thrown during the registration, but those should be fixed with my big cs-cleanup pull request.

Once that clean up will be merged back to master, I'll let you know a17s, so you can test it again.

Thanks!

~0002431

robertbasic (developer)

Hi a17s!

Could you please download again a fresh copy from https://github.com/caseysoftware/web2project/downloads and test it once more, to see if the issue is still there?

Thank you!

~0002469

robertbasic (developer)

Ah, I figured what the -1 is all about.

When registering a new user, the $userid is -1 and that fails the gacl_permissions check in Permissions.class.php::w2Pacl_check so the whole user registration fails.

Will reassign to caseydk to ask for advice on this.

~0002470

a17s (reporter)

Thanks robertbasic. Sorry I did not get to respond earlier. Glad you found the fix.

~0002616

caseydk (administrator)

The fatal error was resolved a while ago but Users still can register externally. That issue is detailed in 0001073.
+Notes

-Issue History
Date Modified Username Field Change
2012-02-20 13:10 a17s New Issue
2012-02-20 13:31 a17s Note Added: 0002407
2012-02-20 22:01 robertbasic Note Added: 0002408
2012-02-21 13:07 a17s Note Added: 0002413
2012-02-26 03:09 robertbasic Note Added: 0002421
2012-03-05 09:25 robertbasic Status new => assigned
2012-03-05 09:25 robertbasic Assigned To => robertbasic
2012-03-05 09:38 robertbasic Note Added: 0002431
2012-04-01 08:36 robertbasic Note Added: 0002469
2012-04-01 08:36 robertbasic Assigned To robertbasic => caseydk
2012-04-02 19:29 a17s Note Added: 0002470
2012-04-21 19:07 caseydk Project v2.4 Release (Closed) => v3.0 Release
2012-08-02 19:33 caseydk Relationship added has duplicate 0001073
2012-08-02 19:34 caseydk Relationship deleted has duplicate 0001073
2012-08-02 19:34 caseydk Relationship added related to 0001073
2012-08-02 19:34 caseydk Note Added: 0002616
2012-08-02 19:34 caseydk Status assigned => resolved
2012-08-02 19:34 caseydk Resolution open => fixed
2013-08-28 11:14 caseydk Fixed in Version => 3.0.0
2013-08-28 11:19 caseydk Status resolved => closed
+Issue History