Anonymous Login
2019-06-24 20:35 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001071v3.0 Release[All Projects] Generalpublic2013-08-28 11:19
Reporteropto 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.0 
Summary0001071: db confusion and install errors - some sql scripts need innodb, others don't
Descriptionsome upgrade scripts ask for innodb engine.

That is highly undesirable because it splits the database into an 'default' part (here: Myisam) plus the engine for the new tables.

Some users (see forum) can't installany longer because their mysql disables innodb. They are only missing the new tables which explicitly ask for innodb.

I propose to continue using the default engine for all tables, or to convert everything to innodb.

Having everything as myisam has the advantge that backup can be done by copying the db directory, if it is innodb, sql needs to be used. Of course, innodb has other advantages.

Klaus
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0002447

caseydk (administrator)

Switched to MySQL in r2399
+Notes

-Issue History
Date Modified Username Field Change
2012-02-27 10:15 opto New Issue
2012-03-18 00:48 caseydk Note Added: 0002447
2012-03-18 00:48 caseydk Status new => resolved
2012-03-18 00:48 caseydk Resolution open => fixed
2012-03-18 00:48 caseydk Assigned To => caseydk
2013-08-28 11:14 caseydk Fixed in Version => 3.0.0
2013-08-28 11:19 caseydk Status resolved => closed
+Issue History