Anonymous Login
2019-08-22 17:23 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001088v3.0 Release[All Projects] Generalpublic2013-08-28 11:18
Reporteropto 
Assigned Tocaseydk 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.0 
Summary0001088: cannot import dynamic tasks + FIX
Descriptionsee http://forums.web2project.net/viewtopic.php?t=4840, fix at end
Additional Informationin importtasks:

updatedynamics is called before children are imported, dates of dyn task set to 0 and storecheck fails.
solution:
1. set all dynamic tasks to not dyn and store. set array of all dynamic task ids
2. after task fixing, loop all these ids, set to dynamic, store (which updates dynamics)
TagsNo tags attached.
Attached Files

-Relationships
has duplicate 0001076closed Pending Requests Import project with dynamic tasks - the date is 29.11.1999 
+Relationships

-Notes

~0002445

project_manager (reporter)

fix works but 3.5x times longer load time as with v.2.3.1.

see: http://forums.web2project.net/viewtopic.php?p=14596#14596

Add. problems of v3.x pre:

1. After import, project views show 0 (!) tasks. Gantt chart generation is not possible, because "no tasks to display"! But all tasks are read and visible under the Tasks-template.

---> probably some status is not set.
---> after changing/saving a task the problem is solved

2. Project end date is not set. See optos post.

~0002712

caseydk (administrator)

I *might* have solved this one by accident here:
https://github.com/caseysoftware/web2project/pull/171

All feedback welcome.

Regardless, I'm going to work on this more in the next day or two.

~0002741

caseydk (administrator)

Resolved: https://github.com/caseysoftware/web2project/pull/174
+Notes

-Issue History
Date Modified Username Field Change
2012-03-14 09:41 opto New Issue
2012-03-15 13:23 project_manager Note Added: 0002445
2012-10-28 20:54 caseydk Relationship added has duplicate 0001076
2012-11-24 22:57 caseydk Note Added: 0002712
2012-11-24 22:57 caseydk Status new => feedback
2012-11-29 12:24 caseydk Note Added: 0002741
2012-11-29 12:24 caseydk Status feedback => resolved
2012-11-29 12:24 caseydk Resolution open => fixed
2012-11-29 12:24 caseydk Assigned To => caseydk
2013-08-28 11:14 caseydk Fixed in Version => 3.0.0
2013-08-28 11:18 caseydk Status resolved => closed
+Issue History