Anonymous Login
2019-08-19 23:05 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001101v3.0 Release[All Projects] Generalpublic2013-08-28 11:18
Reportermelillo 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.0 
Summary0001101: Cannot assign a department to a user
DescriptionIn the User Admin page, I edit a user. In the Edit User page, I click on the "select dept." button. A window "Select Department" appears, containing the departments of my company (see attached image). I click on a department, nothing happens. There is no "Select" button. I can only click on [none] or the Cancel button.

Note that I can however assign a department for that user if I edit the Contact information of that user. In that case the "Select Department" windows works fine, the "Select" button is there, and I can select a department. Curiously, I cannot remove an already assigned department in that window. I must go in the "Select Department" window called from the Edit User page to do that, by clicking "[nono]" in the list of departments.

Note that this behavior (first paragraph) also appears in the View Role page, when I try to add a permission for a given department ("Add permissions window, module Department, and "..." button to select a department).

Thank you.
Additional InformationWeb2Project installed on a Windows Server 2003 Std ed., WampServer version 2.0 (Apache 2.2.11, PHP 5.3.0, MySQL 5.1.36)
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0002528

Korkonius (reporter)

I think this is a JavaScript issue. Would you care to share some details on which browser you are using, and eventual errors in the JS Debug console of that browser?

~0002529

Korkonius (reporter)

I've tested to see if I could reproduce this, and using the latest SVN/GitHub build (Gh commit: 774900b27c) I've been unsuccessful in reproducing the problem using IE9, Chrome 19, FF 12 or Opera 11.64.

The output of the JS console in your browser should hopefully tell you what the problem is an help us solve it...

~0002530

melillo (reporter)

Thank you Korkonius, your hint allowed me to solve the problem. After clicking on a department in the "Select Department" window, I saw this error in the JScript log:
Erreur : missing ) after argument list
Fichier Source : javascript:setClose('1','%C3%89cole%20d'optom%C3%A9trie:%20Ing%C3%A9nierie%20biom%C3%A9dical');
Ligne : 1, Colonne : 22
Code Source :
setClose('1','École d'optométrie: Ingénierie biomédical');

with an arrow pointing the letter "o" in the word "optometrie". So I concluded that the problem was caused bye the apostrophe character in the company name. I modified the company name to remove that character, and the problem was solved.

Thank you very much!

Marc Melillo

~0002601

caseydk (administrator)

This is already resolved in the v3.0 development branch
+Notes

-Issue History
Date Modified Username Field Change
2012-03-20 06:47 melillo New Issue
2012-03-20 06:47 melillo File Added: department_bug.jpg
2012-04-21 19:07 caseydk Project v2.4 Release (Closed) => v3.0 Release
2012-05-19 04:09 Korkonius Note Added: 0002528
2012-05-19 04:30 Korkonius Note Added: 0002529
2012-05-22 07:10 melillo Note Added: 0002530
2012-07-16 22:36 caseydk Note Added: 0002601
2012-07-16 22:36 caseydk Status new => resolved
2012-07-16 22:36 caseydk Resolution open => fixed
2012-07-16 22:36 caseydk Assigned To => caseydk
2013-08-28 11:14 caseydk Fixed in Version => 3.0.0
2013-08-28 11:18 caseydk Status resolved => closed
+Issue History