Anonymous Login
2019-10-14 21:04 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001114v4.0 Release (Planning)Core Infrastructurepublic2017-01-02 13:40
Reportercaseydk 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusfeedbackResolutionfixed 
Product Version 
Target Version4.0Fixed in Version4.0 
Summary0001114: Refactor Table Generation
DescriptionCurrently there is a lot of template code involved in generating all the List Tables. There should be some helper methods that take care of it automatically.

The input parameters will be:

Field Names
Field List
Number of empty header cells before the fields
Number of empty header cells after the fields
The AppUI variable
A Sortable flag
Additional InformationI think the method code will look something like:


Class: w2p_Output_TableHelper
Constructor param: $AppUI
createHeader params: $fieldNames, $fieldList, $pre, $post, $sort

And then something like createRows or processRows to create the batch of rows based on the list data. The set of rows will be harder because of the custom things embedded here and there throughout.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0002467

opto (manager)

Last edited: 2012-03-29 11:58

did you ever consider jquery datatables?

has searching across columns, pagination need notbe done in w2p, can save display settings in cookie, etc.

see datatables on google

Variable length pagination
On-the-fly filtering
Multi-column sorting with data type detection
Smart handling of column widths
 Display data from almost any data source DOM, Javascript array, Ajax file and server-side processing (PHP, C#, Perl, Ruby, AIR, Gears etc)

Scrolling options for table viewport
Fully internationalisable
jQuery UI ThemeRoller support
Rock solid - backed by a suite of 2800 unit tests
 Wide variety of plug-ins inc. TableTools, FixedColumns, KeyTable and more
It's free!


Klaus

~0002468

caseydk (administrator)

Yes, this is primarily to generate the fields/headers that go into the tables themselves.

I think sorting is the first thing that should come out of the PHP and go to jQuery.. just because it's annoying to do on the database side of things due to having to validate fields.

~0003509

caseydk (administrator)

There's likely more refactoring coming but the basics are functional.

~0003850

caseydk (administrator)


I'm changing this issue to acknowledged.

While it's resolved in the v4.0 development branch. That is going to be reviewed commit by commit and merged into a new development branch over the next couple months.

~0003877

opto (manager)

it is especially important to have the <thead> <tbody> <tfoot> tags in the helpers already now.
That would make all jquery processing so much easier - all the table tools depend on these headers.

~0003878

opto (manager)

see last note
+Notes

-Issue History
Date Modified Username Field Change
2012-03-26 19:15 caseydk New Issue
2012-03-26 21:37 caseydk Description Updated
2012-03-26 21:37 caseydk Additional Information Updated
2012-03-29 11:57 opto Note Added: 0002467
2012-03-29 11:58 opto Note Edited: 0002467
2012-03-29 18:55 caseydk Note Added: 0002468
2012-04-21 19:19 caseydk Project v3.0 Release => Pending Requests
2012-04-24 22:14 caseydk Project Pending Requests => v3.1 Release
2013-11-27 20:40 caseydk Project v3.1 Release => v3.2 Release
2014-01-21 17:58 caseydk Target Version => 3.2
2014-01-25 00:42 caseydk Category General => Core Infrastructure
2014-02-27 00:30 caseydk Project v3.2 Release => v4.0 Release (Planning)
2014-06-10 22:49 caseydk Target Version 3.2 => 4.0
2014-06-21 22:34 caseydk Note Added: 0003509
2014-06-21 22:34 caseydk Status new => resolved
2014-06-21 22:34 caseydk Fixed in Version => 4.0
2014-06-21 22:34 caseydk Resolution open => fixed
2014-06-21 22:34 caseydk Assigned To => caseydk
2016-12-29 10:16 caseydk Status resolved => acknowledged
2016-12-29 10:16 caseydk Note Added: 0003850
2017-01-02 13:40 opto Note Added: 0003877
2017-01-02 13:40 opto Status acknowledged => feedback
2017-01-02 13:40 opto Note Added: 0003878
+Issue History