Anonymous Login
2019-10-13 22:31 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001143Pending Requests[All Projects] Generalpublic2013-07-04 23:24
Reporterbach 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0001143: LDAP does not work
DescriptionI install web2project 2.4 on openSUSE 64 bit 12.1, PHP 5.3.8, Apache 2.2.21, mySQL 5.5.26.
After success install, I can setup import contact from LDAP with
LDAP Base DN: OU=people,OU=MyBusiness,DC=ourdomainname,DC=ourinstitude,DC=edu
LDAP Host: AD server IP address or hostname
LDAP Port: 389
LDAP Search User Password: self explanatory
LDAP Search User: self explanatory
LDAP User Filter: (objectClass=person)
LDAP Version: 3
I saw it can return the first 1000 people

However, I use the almost the same setup above for LDAP but I can't login with the setting below:
LDAP Settings
LDAP also allows standard login: yes
LDAP Base DN: OU=people,OU=MyBusiness,DC=ourdomainname,DC=ourinstitude,DC=edu
LDAP Host: AD server IP address or hostname
LDAP Port: 389
LDAP Search User Password: self explanatory
LDAP Search User: self explanatory
LDAP User Filter: (&(objectCategory=person)(objectClass=user)(samaccountname=%USERNAME%))
LDAP Version: 3

I check the error code in apache log (error.log) and it is complain about binding at line 67 of file (LDAPxxx.php)
TagsNo tags attached.
Attached Files

-Relationships
duplicate of 0000947closedcaseydk v3.0 Release LDAP authentication fails if the BINDDN is given as a complete DN 
related to 0001110closed Pending Requests Active Directory error 
+Relationships

-Notes

~0002544

bach (reporter)

1) If I changed the file: /web2project/classes/w2p/Authenticators/LDAP.class.php
at line 55: from
  $ldap_bind_dn = 'CN='.$this->ldap_search_user.',OU=Users,'.$this->base_dn;
to
  $ldap_bind_dn = empty($this->ldap_search_user) ? null:$this->ldap_search_user;

I saw the log, it can't create user id, but I saw it created the contact user.

2) If I add the user ID and assign temporary password, I can login with my LDAP password and also my temporary password - it is not good - I want the temporary has to be disable.

~0002673

caseydk (administrator)

Dupe of 0000947
+Notes

-Issue History
Date Modified Username Field Change
2012-05-29 07:13 bach New Issue
2012-05-30 04:42 bach Note Added: 0002544
2012-07-08 20:30 caseydk Project v2.4 Release (Closed) => v3.0 Release
2012-07-29 10:15 caseydk Tag Attached: 1110
2012-07-29 10:15 caseydk Tag Detached: 1110
2012-07-29 10:15 caseydk Relationship added related to 0001110
2012-07-29 10:16 caseydk Relationship added duplicate of 0000947
2012-10-28 20:19 caseydk Note Added: 0002673
2012-10-28 20:19 caseydk Duplicate ID 0 => 947
2012-10-28 20:19 caseydk Status new => resolved
2012-10-28 20:19 caseydk Resolution open => duplicate
2012-10-28 20:19 caseydk Assigned To => caseydk
2012-10-28 20:20 caseydk Status resolved => closed
2013-07-04 23:24 caseydk Project v3.0 Release => Pending Requests
+Issue History