Anonymous Login
2019-10-20 19:55 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001159v3.0 Release[All Projects] Generalpublic2013-08-28 11:18
Reporterproject_manager 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.0 
Summary0001159: email Task Reminder: task_dates empty in email
DescriptionTask Reminder:

in tasks\tasks.clss.php

public function remind($module, $type, $id, $owner, &$args) {
...
$this->_AppUI->loadPrefs($user_id);

---> problem in: CAppUI.class.php
--------------------------------
public function loadPrefs($uid = 0, $return = false)
...
buggy code
...
--------------------------------
$df = $this->_AppUI->getPref('DISPLAYFORMAT');
---> $df becomes unvalid due to processing bug

$body = str_replace('START-TIME', $starts->convertTZ($tz)->format($df), $body);
$body = str_replace('END-TIME', $expires->convertTZ($tz)->format($df), $body);
---> format($df) delivers '' instead of a task_time.
Additional Informationw2p 3.x-2213: loadPrefs() ---> ok!
w2p 3.x-2470: loadPrefs() ---> wrong!
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0002670

caseydk (administrator)

Resolved: https://github.com/caseysoftware/web2project/pull/147
+Notes

-Issue History
Date Modified Username Field Change
2012-07-02 09:29 project_manager New Issue
2012-08-07 21:10 caseydk Status new => assigned
2012-08-07 21:10 caseydk Assigned To => caseydk
2012-10-28 17:26 caseydk Note Added: 0002670
2012-10-28 17:26 caseydk Status assigned => resolved
2012-10-28 17:26 caseydk Resolution open => fixed
2013-08-28 11:14 caseydk Fixed in Version => 3.0.0
2013-08-28 11:18 caseydk Status resolved => closed
+Issue History