Anonymous Login
2019-02-21 12:27 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001168v3.0 Release[All Projects] Generalpublic2013-08-28 11:18
ReporterKorkonius 
Assigned Totrevormorse 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.0 
Summary0001168: System Administration screen layout is messed up
DescriptionProbably as a result of some of the most recent CSS cleanups the system admin layout is now gone a bit awry. The behavior is identical in Chrome 13 and Firefox 13.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0002613

caseydk (administrator)

What is your screen resolution?

~0002638

lukeD (reporter)

The problem is caused by the long "Please set an email address..." message. It takes up too much space and causes the layout problem on smaller screens. Once you enter a proper admin email address the message goes away and the layout is back to normal. But when you make the browser window small enough (<800px) the same problem occurs.

So I played around with the css and html and found that adding a empty div with style "clear: both" after every row helps keep the divs from jumping to different rows. And adding "max-width:75%" (or something in that range) to the .left class will keep the text part (<div class="left">) from pushing the icon (<div class="left icon">) away.

~0002639

Korkonius (reporter)

My screen resolution is 1600x900 so the issue is not a small screen i think. As lukeD says it is probably due to the error message...

~0002640

trevormorse (manager)

Thanks lukeD, used part of your suggestion in the fix. It can be seen here - https://github.com/caseysoftware/web2project/pull/136
+Notes

-Issue History
Date Modified Username Field Change
2012-08-01 01:44 Korkonius New Issue
2012-08-01 01:44 Korkonius File Added: w2p_bugreport_sysadminlayout.png
2012-08-02 16:32 caseydk Note Added: 0002613
2012-08-02 16:32 caseydk Status new => feedback
2012-08-20 08:01 lukeD Note Added: 0002638
2012-08-21 03:32 Korkonius Note Added: 0002639
2012-08-26 15:22 trevormorse Status feedback => assigned
2012-08-26 15:22 trevormorse Assigned To => trevormorse
2012-08-26 15:22 trevormorse Status assigned => confirmed
2012-08-26 15:28 trevormorse Note Added: 0002640
2012-08-26 15:28 trevormorse Status confirmed => resolved
2012-08-26 15:28 trevormorse Resolution open => fixed
2013-08-28 11:14 caseydk Fixed in Version => 3.0.0
2013-08-28 11:18 caseydk Status resolved => closed
+Issue History