Anonymous Login
2019-02-21 16:43 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001196v3.0 Release[All Projects] Generalpublic2013-08-28 11:18
Reporterchdrsto 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.0 
Summary0001196: The Owner and project_type and project_contacts are not displayed in Project list view
DescriptionThere are three issues in the project list view.

1) The Project Owner is not displayed with the name. It shows the UID number of the Project Owner (ex. "1").
2) The project_type has the same issue as above.
3) Project_contacts are empty

See the Attachment
Additional InformationVerified in the last build (cd295d1) and (823f421)
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0002686

caseydk (administrator)

3) The project_contacts (and project_department) fields are legacy from another project. I've added a patch to remove those from the config screen.

The other two will need tweaking.

~0002688

chdrsto (reporter)

This is sad, because I used to use this functionality to see who and from which department is my project contact in the overview.
So I could also sort by contact name or department to have a quick overview.

~0002690

caseydk (administrator)

The list of Project Contacts has *never* been on the Project List screen.
I'm not sure if the Departments were either.


Regardless, the way they're represented here was just plain poor database design that didn't work reliably.

~0002692

caseydk (administrator)

Resolved: https://github.com/caseysoftware/web2project/pull/160
+Notes

-Issue History
Date Modified Username Field Change
2012-11-02 00:56 chdrsto New Issue
2012-11-02 00:56 chdrsto File Added: project_list_issues.jpg
2012-11-02 23:05 caseydk Note Added: 0002686
2012-11-02 23:33 chdrsto Note Added: 0002688
2012-11-04 13:29 caseydk Note Added: 0002690
2012-11-04 17:17 caseydk Note Added: 0002692
2012-11-04 17:17 caseydk Status new => resolved
2012-11-04 17:17 caseydk Resolution open => fixed
2012-11-04 17:17 caseydk Assigned To => caseydk
2013-08-28 11:14 caseydk Fixed in Version => 3.0.0
2013-08-28 11:18 caseydk Status resolved => closed
+Issue History