Anonymous Login
2021-12-07 21:39 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001203Pending Requests[All Projects] Generalpublic2012-11-21 21:34
Reporterinter71 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0001203: Moving from dotProject 2.16 tables are not correctly converted
DescriptionWhen migrating from dotproject 2.1.6 to web2project 2.4, after migration I get nothing but a blank screen and error 500.

This is the sequence of step I've done.
Unzipped web2project on a folder named web2project
Copied folder files form dotproject to web2project
Copied file config.php
Modified file UpgradeManager.class.php adding line case '2.1.6': immediately after line case '2.1.5':
Start the installation http://127.0.0.1:4001/web2project/install/


When I start the conversion it tells me the message above and the following:
onfig file could not be written
The following content should go to ./includes/config.php. Create that text file manually and copy the following lines in by hand. This file must be readable by the webserver.
Failure to create this file as instructed will render your web2project installation non-operational.
Save yourself (and us!) some time and please follow directions. Thanks.

I replaced the content of config.php with the one proposed and tried to login but it failed error 500.

I'v added line "case '2.1.6':" in classes/w2p/Core/UpgradeManager.class.php with no luck.

The only way to fix the prolem was to remove the prefix dotp_ froma ll tables. I had to do it even if I specified the dbprefix in config.php.

In my opinion if I can specify the dbprefix it should work with this prefix.
TagsNo tags attached.
Attached Files

-Relationships
duplicate of 0000648closedcaseydk Make the Install Script Table Prefix Aware 
+Relationships

-Notes

~0002696

caseydk (administrator)

I'm closing this one not because it's resolved but because this is a duplicate.

At present, web2project does not formally support database prefixes but is on the agenda post v3.0. I've updated the converter to stop the process if you are using prefixes.
+Notes

-Issue History
Date Modified Username Field Change
2012-11-09 02:28 inter71 New Issue
2012-11-21 21:15 caseydk Relationship added child of 0000648
2012-11-21 21:34 caseydk Note Added: 0002696
2012-11-21 21:34 caseydk Relationship replaced duplicate of 0000648
2012-11-21 21:34 caseydk Duplicate ID 0 => 648
2012-11-21 21:34 caseydk Status new => resolved
2012-11-21 21:34 caseydk Resolution open => duplicate
2012-11-21 21:34 caseydk Assigned To => caseydk
2012-11-21 21:34 caseydk Project v2.4 Release (Closed) => Pending Requests
2012-11-21 21:34 caseydk Status resolved => closed
+Issue History