Anonymous Login
2019-09-19 09:54 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001233v3.0 Release[All Projects] Generalpublic2013-08-28 11:17
Reporteropto 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.0 
Summary0001233: cannot select tasks, only all checkbox works in google chrome
Descriptionthe task checkboxes don't work, only the all tasks checkbox in chrome
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0002771

dlw1660 (reporter)

just the opposite in IE Can't select all but can select indivisual tasks. using IE 8, 9 and 10 all the same

~0002783

jonhalle (reporter)

I have had a bit of a review of this one. Seems that handling of clicks in those boxes is rather overcomplicated and falling foul of browser differences in the timing of onblur at least. I don't see the need for the 'magic' on_check global and i think it is creating problems. i had some success with removing select_box entirely and replacing select_row with a much simpler version.

function select_row(box, id, form_name){

        boxObj = document.getElementById(box+'_'+id);
        if (boxObj.disabled) return;
        if (boxObj.checked) {
            addBulkComponent(id);
        } else {
            removeBulkComponent(id);
        }
}

seems to work on chrome. can't test here in IE. i may be missing a workaround for some other problem - but the current system of using 3 different tests whether a checkbox is checked looks like code-upon-code (use of 'eval' implies a php coder wrestling with js!) and is i think the source of the x-browser issues.

~0002791

caseydk (administrator)

Resolved: https://github.com/web2project/web2project/pull/196
+Notes

-Issue History
Date Modified Username Field Change
2012-12-25 19:19 opto New Issue
2012-12-31 23:47 caseydk Status new => assigned
2012-12-31 23:47 caseydk Assigned To => caseydk
2013-01-10 15:28 dlw1660 Note Added: 0002771
2013-02-03 15:54 jonhalle Note Added: 0002783
2013-02-19 22:10 caseydk Note Added: 0002791
2013-02-19 22:10 caseydk Status assigned => resolved
2013-02-19 22:10 caseydk Resolution open => fixed
2013-08-28 11:14 caseydk Fixed in Version => 3.0.0
2013-08-28 11:17 caseydk Status resolved => closed
+Issue History