Anonymous Login
2019-06-19 06:09 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001247v3.0 Release[All Projects] Generalpublic2013-08-28 11:17
Reporterdlw1660 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.0 
Summary0001247: select all does not work
DescriptionCan not select all using IE have tried IE 8, 9, and 10 updated to last load of 3.0 2/20/2012 still does not work

works using firefox
TagsNo tags attached.
Attached Files

-Relationships
has duplicate 0001293closed Pending Requests can not select all task in project designer 
+Relationships

-Notes

~0002802

caseydk (administrator)


I need help on this one.. I don't have a Windows machine to test IE.

Can anyone else provide some insight?

~0002883

dlw1660 (reporter)

Casey it looks like this is an issue with in modules\projectdesigner\index.js the following works in IE and FF its the only two i could check. it shouldnt break anything but if you could look at it

function select_all_rows(cmbObj, elements_name) {
    var checked = cmbObj.checked;
    var checkboxes = document.getElementsByName(elements_name);

   - for (var i in checkboxes) {
   + for (var i = 0; i < checkboxes.length; i++) {
        id = checkboxes[i].value;
        checkboxes[i].checked = checked;

        result = (checked) ? addBulkComponent(id) : removeBulkComponent(id);

~0002885

caseydk (administrator)

Resolved as described here:
https://github.com/web2project/web2project/commit/9699f46523cd6b01459fda8e891950542e85c72f
+Notes

-Issue History
Date Modified Username Field Change
2013-02-22 17:01 dlw1660 New Issue
2013-02-26 21:18 caseydk Note Added: 0002802
2013-02-26 21:18 caseydk Status new => feedback
2013-02-27 19:52 caseydk Project v3.0 Release => Pending Requests
2013-03-30 10:59 caseydk Relationship added has duplicate 0001293
2013-04-05 13:44 dlw1660 Note Added: 0002883
2013-04-07 12:24 caseydk Project Pending Requests => v3.0 Release
2013-04-07 13:20 caseydk Note Added: 0002885
2013-04-07 13:20 caseydk Status feedback => resolved
2013-04-07 13:20 caseydk Resolution open => fixed
2013-04-07 13:20 caseydk Assigned To => caseydk
2013-08-28 11:14 caseydk Fixed in Version => 3.0.0
2013-08-28 11:17 caseydk Status resolved => closed
+Issue History