Anonymous Login
2019-08-20 00:12 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001250v3.0 Release[All Projects] Generalpublic2013-08-28 11:17
Reportersasquatch58 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.0 
Summary0001250: offsets start date by locale difference on Update
Description- existing task created with
    start date of 2013-02-28 08:00 NZDST in db as 2013-02-27 19:00:00 (correct)
    end date of 2013-03-06 12:00 NZDST in db as 2013-03-05 23:00:00 (correct)
    Duration 36h (correct)
    time of entry 2013-02-28 21:36 NZDST in db as 2013-02-28 08:36:27 (correct)
- modify task within normal Project View or Task View, no issues with changes
- modify task within Project Designer & start date moves back by increments of 13h
    change Task type from Admin to Unknown & start time changed to 2013-02-27 06:00 NZDST, in db as 2013-02-26 17:00:00
        duration & finish date stayed same
    change Task priority to normal & start time changed to 2013-02-26 17:00 NZDST, in db as 2013-02-26 04:00:00
        duration & finish date stayed same
Conclusion - there's an issue with Project Designer updates & Timezones. I'd suggest current db task Start Time value is being treated as user locale and the timezone correction is being applied.
Additional InformationWeb2project V3.0-pre
Git version 3186736eec00dcf27b004f8f886813ffe0fc7888

Server timezone UTC+13 (NZDST)
User timezone UTC+13 (NZDST)

Server - Ubuntu 12.04LTS
Client - Windows XP Pro, Firefox
TagsNo tags attached.
Attached Files

-Relationships
related to 0001321closedopto bulk add increasing time by 5 hours when date not selected 
+Relationships

-Notes

~0002930

caseydk (administrator)

While this is another form of 0001321, I'm not marking either as a duplicate as both were useful in tracking down the root cause.

(Marking an item as a duplicate lowers a bug reporter's "effectiveness" rating in the admin reports within this bug tracking system.)
+Notes

-Issue History
Date Modified Username Field Change
2013-02-28 01:03 sasquatch58 New Issue
2013-06-02 20:52 caseydk Relationship added related to 0001321
2013-06-02 20:52 caseydk Relationship replaced duplicate of 0001321
2013-06-02 20:53 caseydk Relationship replaced related to 0001321
2013-06-02 20:54 caseydk Note Added: 0002930
2013-06-02 20:54 caseydk Status new => resolved
2013-06-02 20:54 caseydk Resolution open => fixed
2013-06-02 20:54 caseydk Assigned To => caseydk
2013-08-28 11:14 caseydk Fixed in Version => 3.0.0
2013-08-28 11:17 caseydk Status resolved => closed
+Issue History