Anonymous Login
2019-10-18 04:40 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001251v3.0 Release[All Projects] Generalpublic2013-08-28 11:17
Reportersasquatch58 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.0 
Summary0001251: Unable to delete task dependencies from normal Task editing window
Description- can assign a dependency in the normal Task editing window but can't delete it from here
- can assign a dependency in the Project Designer and can delete it from here
Additional InformationWeb2project V3.0-pre
Git version 3186736eec00dcf27b004f8f886813ffe0fc7888

Server Ubuntu 12.04LTS
Server timezone UTC+13 (NZDST)
User timezone UTC+13 (NZDST)
Client Win XP Pro - Firefox
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0002827

caseydk (administrator)

Unable to reproduce with latest github development.

~0002830

sasquatch58 (reporter)

Still present in my test environment with latest git pull ec32990012af0e208ab67a32c6d48d0c36448946

Method to reproduce.
1. Create a task and set a dependency on a previous task within the task creation window. Tick start date based on dependency. Save/ close.
2. Re-edit task directly, move the dependent task from the window by highlighting and clicking "<". Save/ close.

Look at the task info - dependency is still showing in the task details ie dependency not deleted.

3. Working method. Go to Project Designer, select the task and choose Remove dependencies option and update. Dependency is now gone from Task detail.

~0002831

caseydk (administrator)

Works as expected on FF on Ubuntu, but you are correct.. it doesn't work in either Safari or Chrome on OSX. I'm not sure if it's webkit or something else at this point.

~0002850

carlosazevedo (reporter)

Fixed in my fork: https://github.com/carlosazevedo/web2project/commit/1c7b0599c02bd9c5a44e66f9586b173ce0718783

~0002875

opto (manager)

there may be another flavour of this bug:

it doesn't work in FF either on the 2013-3-31 version if a singlr dependency is removed.
In this case, $hdependencies is empty string in do task aed.php.
The code in do_task_aed explicitly does NOT deal with this condition.

    if (isset($hdependencies) && '' != $hdependencies) {
        // there are dependencies set!

~0002884

caseydk (administrator)

Resolved as described here:
https://github.com/web2project/web2project/commit/25d85bf2b81675cd812f377319e5db5171680f2c
+Notes

-Issue History
Date Modified Username Field Change
2013-02-28 01:05 sasquatch58 New Issue
2013-03-03 21:49 caseydk Note Added: 0002827
2013-03-03 21:49 caseydk Status new => closed
2013-03-03 21:49 caseydk Resolution open => unable to reproduce
2013-03-03 22:38 sasquatch58 Note Added: 0002830
2013-03-03 22:38 sasquatch58 Status closed => feedback
2013-03-03 22:38 sasquatch58 Resolution unable to reproduce => reopened
2013-03-03 22:47 caseydk Note Added: 0002831
2013-03-15 03:28 carlosazevedo Note Added: 0002850
2013-03-31 08:00 opto Note Added: 0002875
2013-04-07 13:20 caseydk Note Added: 0002884
2013-04-07 13:20 caseydk Status feedback => resolved
2013-04-07 13:20 caseydk Resolution reopened => fixed
2013-04-07 13:20 caseydk Assigned To => caseydk
2013-08-28 11:14 caseydk Fixed in Version => 3.0.0
2013-08-28 11:17 caseydk Status resolved => closed
+Issue History