Anonymous Login
2019-08-20 00:14 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001252v3.2 ReleaseTaskspublic2014-07-16 21:28
Reportersasquatch58 
Assigned Tocaseydk 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target Version3.2Fixed in Version3.2 
Summary0001252: Gantt charts offset by UTC to User locale time difference when viewed in "show full project" mode
Description- in "show this month", bar chart display follows user locale (all OK)
- in "show full project", bar chart display follows database value with no correction for user locale. This results in a visual offset of up to 13h
Additional InformationWeb2project V3.0-pre
Git version 3186736eec00dcf27b004f8f886813ffe0fc7888

Server Ubuntu 12.04LTS
Server timezone UTC+13 (NZDST)
User timezone UTC+13 (NZDST)
Client Win XP Pro - Firefox
TagsNo tags attached.
Attached Files

-Relationships
related to 0001266closedcaseydk v3.2 Release "Show all" on gantt chart for Departments 
parent of 0001268closedcaseydk v3.0 Release My tasks to do/ My Gantt - displays incorrectly on "Show All" 
+Relationships

-Notes

~0002813

sasquatch58 (reporter)

Last edited: 2013-03-02 21:44

Testing various gantt views that appear for timezone related issues
- Projects/Gantt View - summary (Project bar) works OK in both display modes, task bars (when selected) are incorrect in both views
- View Project/ Gantt Chart - displays incorrectly on "Show All"
- My tasks to do/ My Gantt - displays incorrectly on "Show All"
- View Department/ Projects Gantt - summary (Project bar) works OK in both views, task bars (when selected) are incorrect in both views

~0002816

caseydk (administrator)

Other than the "My Tasks" View (0001268), the rest of these are super low priority because in order to notice that timezone oddness, you have to have less than 90 days visible on the Gantt Chart.

~0002916

sasquatch58 (reporter)

More testing against git a7863616ee shows that the issue appears to be related to any task that starts prior to the current date. If one task starts before curren tdate then all will be offset by timezone on Show All. Where all tasks are in the future, there's no issues.

~0003429

caseydk (administrator)

Resolved in development:
https://github.com/web2project/web2project/commit/f1f72ab868017b48fa15b7e3650525cd6d6b8f5b
+Notes

-Issue History
Date Modified Username Field Change
2013-02-28 01:07 sasquatch58 New Issue
2013-03-02 21:32 sasquatch58 Note Added: 0002813
2013-03-02 21:44 sasquatch58 Note Edited: 0002813
2013-03-02 22:56 caseydk Relationship added related to 0001266
2013-03-02 22:58 caseydk Relationship added parent of 0001268
2013-03-02 23:01 caseydk Note Added: 0002816
2013-03-02 23:01 caseydk Project v3.0 Release => Pending Requests
2013-03-02 23:01 caseydk Priority normal => low
2013-03-02 23:01 caseydk Status new => acknowledged
2013-06-01 18:07 sasquatch58 Note Added: 0002916
2014-04-05 17:35 caseydk Category General => Calendar
2014-04-05 17:36 caseydk Category Calendar => Tasks
2014-06-10 22:08 caseydk Project Pending Requests => v3.2 Release
2014-06-10 22:08 caseydk Note Added: 0003429
2014-06-10 22:08 caseydk Status acknowledged => resolved
2014-06-10 22:08 caseydk Resolution open => fixed
2014-06-10 22:08 caseydk Assigned To => caseydk
2014-06-10 22:09 caseydk Target Version => 3.2
2014-07-16 21:26 caseydk Fixed in Version => 3.2
2014-07-16 21:28 caseydk Status resolved => closed
+Issue History