Anonymous Login
2019-02-16 21:26 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001257v3.2 ReleasePDF Generationpublic2014-07-16 21:30
Reportersimonnzg 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target Version3.2Fixed in Version3.2 
Summary0001257: Gantt chart print to PDF only shows the first 24 tasks
DescriptionAfter not having used Gantt charts before, we now have a PM that likes them. He's complaining that when he tries to print Gantt charts to PDF it only prints the first 24-or-so tasks and then stops and prints the chart key (in much larger type).

Additional InformationI have suggested a workaround in that he simply right-clicks the chart on the web page and downloads it, but I haven't been able to overcome this PDF generation problem.
TagsNo tags attached.
Attached Files

-Relationships
duplicate of 0001248closedcaseydk Pending Requests view gantt in PDF incomplete 
has duplicate 0000396closed Pending Requests Multipage Gantt chart error 
has duplicate 0001294closed Pending Requests Gantt not generating complete chart when printing to PDF 
has duplicate 0001375closedcaseydk Pending Requests PDF Gantt Chart only showing first 22 task 
+Relationships

-Notes

~0002807

caseydk (administrator)

Last edited: 2013-03-02 23:23

Since there's an easy work around for this one (Show Full Project -> view image -> print to PDF), I'm pushing this beyond the v3.0 release.

FYI: There *is* Gantt chart pagination code built into the PDF generation but it doesn't seem to work as expected

~0002821

dlw1660 (reporter)

Using IE this work around doesn't work

~0003485

caseydk (administrator)

Finally resolved this one for v4.0 but you should be able to just grab this patch:
https://github.com/web2project/web2project/commit/c7c31631172062124c55107df92b88847ea68e61

My test projects had 22, 105, and 364 tasks and each worked as expected.

~0003504

caseydk (administrator)

Backported this fix to v3.2
+Notes

-Issue History
Date Modified Username Field Change
2013-02-28 04:19 simonnzg New Issue
2013-03-02 14:17 caseydk Note Added: 0002807
2013-03-02 14:17 caseydk Project v3.0 Release => Pending Requests
2013-03-02 23:23 caseydk Note Edited: 0002807
2013-03-02 23:23 caseydk Relationship added has duplicate 0000396
2013-03-03 04:14 dlw1660 Note Added: 0002821
2013-03-30 10:48 caseydk Relationship added has duplicate 0001294
2014-06-10 21:44 caseydk Relationship added has duplicate 0001375
2014-06-10 21:44 caseydk Project Pending Requests => v4.0 Release (Planning)
2014-06-10 22:43 caseydk Relationship added duplicate of 0001248
2014-06-10 22:49 caseydk Target Version => 4.0
2014-06-12 19:47 caseydk Category General => PDF Generation
2014-06-14 19:50 caseydk Note Added: 0003485
2014-06-14 19:50 caseydk Status new => resolved
2014-06-14 19:50 caseydk Fixed in Version => 4.0
2014-06-14 19:50 caseydk Resolution open => fixed
2014-06-14 19:50 caseydk Assigned To => caseydk
2014-06-19 20:56 caseydk Note Added: 0003504
2014-06-22 12:36 caseydk Project v4.0 Release (Planning) => v3.2 Release
2014-06-22 12:36 caseydk Fixed in Version 4.0 => 3.2
2014-06-22 12:36 caseydk Target Version 4.0 => 3.2
2014-07-16 21:30 caseydk Status resolved => closed
+Issue History