Anonymous Login
2019-08-19 03:28 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001260Pending Requests[All Projects] Generalpublic2013-11-21 19:06
Reportercarlosazevedo 
Assigned Tocaseydk 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0001260: Contact is access denied if its Company has been deleted
DescriptionCorrection: The bug isn't caused by the user being deleted but instead by the company associated to the contact being deleted.
If that happens I get an Access Denied error.
Additional InformationOriginal comment:

If a user record is deleted then its contact record cannot be viewed, bombing with a permission error. I'm assuming this has to do with the way the user records are filtered, requiring both a row in 'users' and another in 'contacts' for it to be considered a valid user. If both rows are not present permission errors will insue as the permission tests will fail.
So either a delete op on a user should delete its contact info also or the permission tests should be fixed.
TagsNo tags attached.
Attached Files

-Relationships
related to 0000686closed The User deletion doesn't delete the contact 
+Relationships

-Notes

~0002806

carlosazevedo (reporter)

Last edited: 2013-03-01 03:35

Correction: The bug isn't caused by the user being deleted but instead by the company associated to the contact being deleted.
If that happens I get an Access Denied error.

~0002856

caseydk (administrator)

This was not truly fixed but with this commit, the situation should not happen again: https://github.com/web2project/web2project/commit/d647214267213b68b39b66b70460e1f073088a44

If you have Contacts attached to deleted Companies, please update their contact_company to zero via the database.
+Notes

-Issue History
Date Modified Username Field Change
2013-03-01 03:09 carlosazevedo New Issue
2013-03-01 03:25 carlosazevedo Note Added: 0002806
2013-03-01 03:35 carlosazevedo Note Edited: 0002806
2013-03-02 23:18 caseydk Relationship added related to 0000686
2013-03-03 21:49 caseydk Category -- none specified -- => User Admin
2013-03-03 22:41 caseydk Summary If a user record is deleted the contact info cannot be accessed => Contact is access denied if its Company has been deleted
2013-03-03 22:41 caseydk Description Updated
2013-03-03 22:41 caseydk Additional Information Updated
2013-03-03 22:49 caseydk Severity major => crash
2013-03-13 22:05 caseydk Project v3.0 Release => Pending Requests
2013-03-16 22:51 caseydk Note Added: 0002856
2013-03-16 22:51 caseydk Status new => resolved
2013-03-16 22:51 caseydk Resolution open => fixed
2013-03-16 22:51 caseydk Assigned To => caseydk
2013-11-21 19:05 caseydk Project Pending Requests => v3.1 Release
2013-11-21 19:06 caseydk Project v3.1 Release => Pending Requests
2013-11-21 19:06 caseydk Status resolved => closed
+Issue History