Anonymous Login
2019-02-22 12:41 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001299v3.0 Release[All Projects] Generalpublic2013-08-28 11:17
Reporteropto 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.0 
Summary0001299: default adminstrator role has no permissions
Descriptiongit 2013-3-31:

create new user with role administrator.

This user then has no permissions, he cannot view any projects.
While this can be easily resolved and granted by hmself, it may cause a loadful of forum complaints because it is illogical to supply this role with no permissions.
People testing w2p will create new admistrators and then complain that the new admins cannot do anything.

I suggest the standard set of roles should be provided with appropriate permissons to try w2p without having to learn the permission system first.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0002886

caseydk (administrator)

tweaked the user creation to remove the (meaningless) User Type field;
Resolved: https://github.com/web2project/web2project/commit/79e6cf352b3c7de95e8e429e76eafc4365d6ddc2
+Notes

-Issue History
Date Modified Username Field Change
2013-03-31 08:59 opto New Issue
2013-04-07 15:11 caseydk Note Added: 0002886
2013-04-07 15:11 caseydk Status new => resolved
2013-04-07 15:11 caseydk Resolution open => fixed
2013-04-07 15:11 caseydk Assigned To => caseydk
2013-08-28 11:14 caseydk Fixed in Version => 3.0.0
2013-08-28 11:17 caseydk Status resolved => closed
+Issue History