Anonymous Login
2019-02-23 05:34 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001341v3.0 Release[All Projects] Generalpublic2013-08-28 11:17
Reporteropto 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0.0 
Summary0001341: FIX: bug in CTask->store: no handling after parent::store
Descriptionupdatedynamics and other are not done because wrong handling of result of parent::store:
currently:
if ((msg=parent::store)) ... then return

this seems wrong because parent::store returns true upon success (at least, it returns false upon some other fails).

replace by if (!(msg=parent::store)) ....

then updatedynamics and other code following parent::store is properly run.

Klaus
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

+Notes

-Issue History
Date Modified Username Field Change
2013-06-25 09:47 opto New Issue
2013-06-25 09:48 opto Status new => assigned
2013-06-25 09:48 opto Assigned To => caseydk
2013-08-03 22:45 caseydk Note Added: 0002984
2013-08-03 22:45 caseydk Status assigned => resolved
2013-08-03 22:45 caseydk Resolution open => fixed
2013-08-28 11:14 caseydk Fixed in Version => 3.0.0
2013-08-28 11:17 caseydk Status resolved => closed
+Issue History