Anonymous Login
2019-06-20 10:10 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001361v3.1 ReleaseTaskspublic2015-04-16 04:20
Reportersasquatch58 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.1 
Summary0001361: Incorrect % complete calculations for dynamic tasks
DescriptionThe calculation of task and project % complete is incorrect for dynamic tasks.
Dynamic tasks have 127% complete where child tasks are nowhere near this.

See attached screen capture.
Additional Informationw2p V3 git 7571db7c454b37e0439eb521e4206f21d28479b7

Ubuntu 12.04 LTS 64 bit
TagsNo tags attached.
Attached Files

-Relationships
duplicate of 0001423closedcaseydk v3.1 Release Using latest GIT code the % calculation is wrong with nested dynamic tasks 
parent of 0001360closedcaseydk v3.0 Release Dynamic task - duration calculations 
+Relationships

-Notes

~0002992

caseydk (administrator)

Can you update and try this one again?

I can't tell if it's resolved or I just can't reproduce it..

~0002993

sasquatch58 (reporter)

Still appears to be an issue at git a8124d84628119e49369fd81b28d93e5c9eefe2f
Screen capture below after updating some tasks to refresh.

~0002994

caseydk (administrator)

Still no luck reproducing this one.. I've tried using just hours, just days, and both.. :(

Can anyone else reproduce this one?

~0002995

sasquatch58 (reporter)

Further investigation.
- created brand new project, two child tasks & parent task.
Added some effort and assessed completion & all looks OK but...
- added a second parent as you could get in some project groupings and % complete for previous parent task goes back to 0%. See new screen captures.

~0003001

caseydk (administrator)

If this is only happening with nested dynamic tasks, I'm ready to call this lower priority to get v3.0 officially released.

Released with a few minor issues is better than near-perfect and still not released.

~0003160

caseydk (administrator)

Resolved as desribed in 0001423

~0003181

caseydk (administrator)

Closed for v3.1 Release which occurred 20 January 2014.
+Notes

-Issue History
Date Modified Username Field Change
2013-08-07 23:51 sasquatch58 New Issue
2013-08-07 23:51 sasquatch58 File Added: v3-pre work calc errors.png
2013-08-08 10:34 caseydk Relationship added parent of 0001360
2013-08-23 22:30 caseydk Note Added: 0002992
2013-08-23 22:30 caseydk Status new => feedback
2013-08-24 01:22 sasquatch58 Note Added: 0002993
2013-08-24 01:22 sasquatch58 File Added: 2013-08-24_w2p task view.png
2013-08-24 17:23 caseydk Note Added: 0002994
2013-08-25 01:40 sasquatch58 Note Added: 0002995
2013-08-25 01:40 sasquatch58 File Added: 2013-08-25 with dual parents.png
2013-08-25 01:40 sasquatch58 File Added: 2013-08-25 with single parent.png
2013-08-27 22:33 caseydk Note Added: 0003001
2013-08-28 10:26 caseydk Project v3.0 Release => Pending Requests
2014-01-01 16:36 caseydk Project Pending Requests => v3.1 Release
2014-01-01 17:15 caseydk Relationship added duplicate of 0001423
2014-01-01 17:15 caseydk Note Added: 0003160
2014-01-01 17:15 caseydk Status feedback => resolved
2014-01-01 17:15 caseydk Resolution open => fixed
2014-01-01 17:15 caseydk Assigned To => caseydk
2014-01-21 17:40 caseydk Note Added: 0003181
2014-01-21 17:40 caseydk Status resolved => closed
2014-01-21 17:49 caseydk Fixed in Version => 3.1
2014-01-25 00:35 caseydk Category General => Tasks
+Issue History