Anonymous Login
2019-04-22 20:57 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001389v3.1 ReleaseProjectspublic2014-01-25 00:33
Reportermcandell 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
Product Version 
Target VersionFixed in Version3.1 
Summary0001389: Sort Alphabetically the Project list on Project Reports page
DescriptionWhen there is a huge number of Projects being monitored, is it not easy to look for a specific project to be selected from the overall list, at least alphabetical sorting would help to navigate.
I suggest to implement the project list sorting in this way :

Add on line 29 for ./modules/reports/index.php the line :

asort($project_list);

TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0003021

opto (manager)

yes, I agree very much.
I always need to manually order by name before I can find anything.

not sure whether ordering is by date or id,
alphabetic would be better as default, then a project will always be in the expected line.

Klaus

~0003022

opto (manager)

I just doublechecked: at the moment, it is by id, which would be by creation date.

Doesn't make much sense for a user.
so in code, if sort is empty, set sort by name would be a solution

~0003025

simonnzg (reporter)

Problem is that it's not purely in creation date order. It's in Company and *then* ID order, which is the worst of both worlds. Frankly, I'd prefer vanilla ID order with the option to sort alphabetically. We have 17,000 plus projects and several hundred companies on our database.
For instance, making a new project and then being dumped into a list of 17,000 projects sorted by company name aphabetically and then by ID in reverse sucks big time. If I wanted to get to my new project, I'd have to manually filter by company and then go to the last page to find it.
Having the ability to sort by ID would be nice. Currently, it's not even possible. We use the ID as a main reference. It never changes: the project name and company associated often does.
Clearly, we can't all have what we want, so maybe the focus should be on the defaults, but allow more flexible sorting? Yes, I know that's not as easy as it sounds. :)

~0003030

opto (manager)

I had a look at the most recent git code:

if no orderby is given, it is hardcoded for project end date.
If a column header has been clicked, that is posted as orderby and then also stored in a state variable.

So it would be good to store a default in a sysval and use that if no column has been clicked.
In a first order approximation, that sysval could just store the column name, e.g. project_name for ordering by project name.

Or just change the code - I can point you to where if you want to try that.
It is just replacing the project_end_date by whatever you want as default.

Klaus

~0003031

simonnzg (reporter)

Hi Klaus,
That sounds like a good idea. I put my problem into 0001392 a few days ago, so maybe the two issues should be merged as they're closely related.
I can see that the answer will have to be more elegant than deciding on what gets hardcoded. The ideal place to return to when creating a project would be back at the newly created project so tasks can be added, but then sometimes it is better to return to the projects list (and then one must decide what the user may wish to see there).
And that is just one option for one action of many possible actions in web2project.
Point me to the right place and I'll try out some options. :)
Simon

~0003036

caseydk (administrator)

I just dug into this one.. looks like the project list is loaded here:
https://github.com/web2project/web2project/blob/develop/modules/reports/index.php#L18

which is pulled from this query:
https://github.com/web2project/web2project/blob/develop/modules/projects/projects.class.php#L571

which always sorts by project_name. It is *not* configurable in the Report list.

~0003037

caseydk (administrator)

This was previously solved in v3.1 development.

~0003217

caseydk (administrator)

Closed for v3.1 Release which occurred 20 January 2014.
+Notes

-Issue History
Date Modified Username Field Change
2013-11-13 01:52 mcandell New Issue
2013-11-14 09:34 opto Note Added: 0003021
2013-11-14 09:43 opto Note Added: 0003022
2013-11-18 01:19 simonnzg Note Added: 0003025
2013-11-19 09:07 opto Note Added: 0003030
2013-11-19 09:33 simonnzg Note Added: 0003031
2013-11-21 15:46 caseydk Note Added: 0003036
2013-11-21 15:46 caseydk Project v3.0 Release => v3.1 Release
2013-11-21 15:47 caseydk Note Added: 0003037
2013-11-21 15:47 caseydk Status new => resolved
2013-11-21 15:47 caseydk Resolution open => no change required
2013-11-21 15:47 caseydk Assigned To => caseydk
2014-01-21 17:42 caseydk Note Added: 0003217
2014-01-21 17:42 caseydk Status resolved => closed
2014-01-21 17:49 caseydk Fixed in Version => 3.1
2014-01-25 00:33 caseydk Category General => Projects
+Issue History