Anonymous Login
2019-09-15 07:28 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001396v3.2 ReleaseTaskspublic2014-07-16 21:28
Reporterlloydsystems 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target Version3.2Fixed in Version3.2 
Summary0001396: Random changes to task end date/time on adding task log entries
DescriptionFor some time I have experienced an issue whereby the software would randomly change the finish date/time of a task. I would often be unaware this had happened until viewing the project and its task list. Recent testing has discovered this problem occurs when adding, editing or deleting task log entries. Below are the details of such a test:

1) A project has a task with start date 1/7/13 9:00am and finish 31/7/13 5:00pm.
2) I added a log entry for this task
3) I viewed the project to see the finish had changed to 31/7/13 9:00am - same date but different time.
4) I reset the task finish time back to 5:00pm.
5) I added another task log entry for this project/task.
6) The task finish time had changed back to 31/7/13 9:00am by itself.
7) I again reset the finish time to 5:00pm.
8) I then deleted one of those task log entries.
9) Viewing the project this task finish had now changed to 9/8/13 9:00am.
10) I edited the task and changed the finish to 29/7/13 5:00pm.
11) I deleted the other task log entry I had added.
12) Viewing the project this task finish had changed to 31/7/13 9:00am.

This issue has been discussed on the support forum, topic "random changes to task date/time", here http://support.web2project.net/forums/225852-i-need-help-with-/suggestions/5009441-random-changes-to-task-date-time

In this discussion 'opto' has suggested that the problem may be caused because the task log dialog allows change to the task end date. He also pointed out that he recently solved a similar problem with projectdesigner which may provide code to assist with this issue.
Additional Information1) This problem also existed with previous versions of w2P (2.4, 2.3). However, most task logs were created using the timecard feature, and this did not seem to cause a change to the dates. Timecard does not work under version 3, so all task logs must be created from the task list, and every entry alters the project task dates.

2) If this is the problem, and if it makes the solution quicker/easier, I would recommend removing the task end date from the task log dialog. I don't believe it should be there on a page for users to enter their work log. If task must be changed, then view the project details and edit the task list there.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

+Notes

-Issue History
Date Modified Username Field Change
2013-11-20 11:17 lloydsystems New Issue
2013-11-21 21:32 caseydk Project v3.0 Release => v3.1 Release
2014-01-05 12:07 caseydk Project v3.1 Release => v3.2 Release
2014-01-21 17:58 caseydk Target Version => 3.2
2014-01-25 00:41 caseydk Category General => Tasks
2014-03-31 19:22 caseydk Note Added: 0003282
2014-03-31 19:22 caseydk Status new => resolved
2014-03-31 19:22 caseydk Resolution open => fixed
2014-03-31 19:22 caseydk Assigned To => caseydk
2014-07-16 21:26 caseydk Fixed in Version => 3.2
2014-07-16 21:28 caseydk Status resolved => closed
+Issue History