Anonymous Login
2019-06-20 10:51 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001410v3.1 ReleaseTaskspublic2014-01-25 00:26
Reporteropto 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.1 
Summary0001410: add tasks time /duration problem
Descriptionadd tasks proposes as start date: today + time, end date: today + time + 1 h (ok as default!),
duration -3.1 H (???) and saves with the given start and end dates and duration 0.

My employee also managed to store tasks with start === end (day and hour identical) and duration 1 h in projectdesigner. I would love to gain lifetime in such a way, but suspect that only works in software.
He is preparing templates for 150++ task projects, and is very much grumbling about the usability. Actually, he asked me whether we couldn't switch to some other software due to other problems that also occurred.

... usability seems to need some more work ....


Klaus
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0003080

opto (manager)

calcduration in index.php seems to be wrong: commenting it solves the problem.

In the long run, we want a button as in task addedit, because we, for example never want end = start + duration - between start and end, we work a few hours on the task, but not duration = end - start

~0003081

opto (manager)

calcduration is called when first displaying the line - see last comment
if i comment that, I see the defasult duration of 1 hour, with a correct start and end 1 hour apart.

calcduration is also called when changing a date. This totally screws up: moving the end by 2 days increases duration by 8 hours (maybe it adds working hours?).

I would prefer a behaviour as in addedit of tasks where default all three can be set independently

~0003082

opto (manager)

see pull request and my branch projdes

~0003100

caseydk (administrator)

Resolved for the v3.1 release.
Patch available here: https://github.com/web2project/web2project/pull/239

~0003208

caseydk (administrator)

Closed for v3.1 Release which occurred 20 January 2014.
+Notes

-Issue History
Date Modified Username Field Change
2013-11-26 10:19 opto New Issue
2013-11-26 13:03 opto Note Added: 0003080
2013-11-26 13:08 opto Note Added: 0003081
2013-11-26 13:21 opto Note Added: 0003082
2013-11-27 21:17 caseydk Project v3.0 Release => v3.2 Release
2013-11-27 21:19 caseydk Project v3.2 Release => v3.1 Release
2013-11-28 19:03 caseydk Note Added: 0003100
2013-11-28 19:03 caseydk Status new => resolved
2013-11-28 19:03 caseydk Resolution open => fixed
2013-11-28 19:03 caseydk Assigned To => caseydk
2014-01-21 17:41 caseydk Note Added: 0003208
2014-01-21 17:41 caseydk Status resolved => closed
2014-01-21 17:49 caseydk Fixed in Version => 3.1
2014-01-25 00:26 caseydk Category General => Tasks
+Issue History