Anonymous Login
2019-08-23 20:07 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001415v3.1 ReleaseUser Adminpublic2014-01-25 00:31
Reporteropto 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.1 
Summary0001415: user cannot be edited if contactdetail empty
DescriptionI finally figured out that user edit is now by clicking user name, no longer by clicking edit icon. An edit icon in column header or next to name might have helped.

We have the special problem that some users have no contact name. (were added before the contact methods), and nobody bothered to enter the contact name in addition to user name.
With no name, no link, so user cannot be edited.

Although the column is headed user name, it shows actually the contact name of the user.
Maybe I mixed up username and userid?

Anyway, with the userid gone and the edit icon gone, these users now can only be edited in the db.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0003097

caseydk (administrator)

Resolved, will be in v3.1:
https://github.com/web2project/web2project/commit/196343955916937a646a47b2638ef9157f92b7a1

I resolved this by using the username since that's what the column header says anyway. A user can't exist with a null username so this issue shouldn't be possible going forward.

~0003210

caseydk (administrator)

Closed for v3.1 Release which occurred 20 January 2014.
+Notes

-Issue History
Date Modified Username Field Change
2013-11-28 10:10 opto New Issue
2013-11-28 14:46 caseydk Note Added: 0003097
2013-11-28 14:46 caseydk Status new => resolved
2013-11-28 14:46 caseydk Resolution open => fixed
2013-11-28 14:46 caseydk Assigned To => caseydk
2014-01-21 17:41 caseydk Note Added: 0003210
2014-01-21 17:41 caseydk Status resolved => closed
2014-01-21 17:49 caseydk Fixed in Version => 3.1
2014-01-25 00:31 caseydk Category General => User Admin
+Issue History