Anonymous Login
2019-06-24 16:23 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001552v3.2 ReleaseTaskspublic2014-07-16 21:30
Reporteropto 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
Product Version 
Target Version3.2Fixed in Version3.2 
Summary0001552: tasks per user sql totally (?) broken
Descriptionfeature (I will do): display only projects in progress, maybe have checkbox for others.
Currently, not defined is displayed as well

bug: multiple occurance of same task.
Example:
|-moduletester is a subtask.

in this window, it is displayed as

moduletester

and a few lines further down for same project as:
|-moduletester


another example from daily life:

project FFFFF is complete. Three tasks are not finished.
Actually, that happens. The customer does not seem to bother and has paid.
I would like to keep them unfinished in w2p so we know if he should have a request.
I want these tasks to disappear from my tasks and tasks per user, because project status is complete
TagsNo tags attached.
Attached Files

-Relationships
related to 0001561new Pending Requests Task per user shows tasks for all active projects, should filter by status 
+Relationships

-Notes

~0003411

caseydk (administrator)

Is this an annoyance or does it prevent the form from working as expected?

I ask because the task display in general needs a lot of refactoring. I'm trying to hold off on that for v4.0 to do it once instead of partial solutions now.

~0003415

opto (manager)

I think the multiple occurance of tasks is more than an annoyance.

If a user doesn't know the project structure well, it is not clear whether the tasks are doubletts.

The subtasks moduletester is dispalyed as:

moduletester

and a few lines down as:

|-moduletester

is this the same task? or another with same name? How shouuld my employees know?

I think this window does not display the desxcription popup - that would help.

~0003454

caseydk (administrator)

The duplicate task issue is resolved in development:
https://github.com/web2project/web2project/commit/7dd688aa6d933ad45b9c062cac86f6803b491828

~0003455

caseydk (administrator)

The rest of this issue related to only displaying certain project statuses is a feature request, so I'm creating a related issue and attaching it here: 0001561

~0003456

caseydk (administrator)

The bug portion is resolved in development, the rest is separated out as a feature request.
+Notes

-Issue History
Date Modified Username Field Change
2014-05-26 03:38 opto New Issue
2014-05-26 03:46 opto Description Updated View Revisions
2014-06-02 22:19 caseydk Note Added: 0003411
2014-06-02 22:19 caseydk Assigned To => caseydk
2014-06-02 22:19 caseydk Status new => feedback
2014-06-06 13:24 opto Note Added: 0003415
2014-06-06 13:24 opto Status feedback => assigned
2014-06-10 22:09 caseydk Target Version => 3.2
2014-06-12 22:12 caseydk Note Added: 0003454
2014-06-12 22:14 caseydk Note Added: 0003455
2014-06-12 22:14 caseydk Relationship added related to 0001561
2014-06-12 22:14 caseydk Note Added: 0003456
2014-06-12 22:14 caseydk Status assigned => resolved
2014-06-12 22:14 caseydk Resolution open => fixed
2014-06-12 22:15 caseydk Fixed in Version => 3.2
2014-07-16 21:30 caseydk Status resolved => closed
+Issue History