Anonymous Login
2019-11-17 22:30 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001565Pending RequestsTaskspublic2016-12-26 10:25
Reporteropto 
Assigned Tocaseydk 
PrioritynormalSeverityfeatureReproducibilityhave not tried
StatusfeedbackResolutionreopened 
Product Version 
Target VersionFixed in Version 
Summary0001565: dependency tracking moves only forward, not backward
Descriptionb depends on a.

I decide b ends too late.
I change a so that it ends earlier. Then, b can start earlier.

although dep tracking, b still stays at its start date (should shift to new end date of a

I think we had this already, wasn't it solved?
How can I do project planning without this?

maybe make ths an option in sysadmin?
TagsNo tags attached.
Attached Files

-Relationships
duplicate of 0001419new Can't Set Linked Task To Earlier Date 
+Relationships

-Notes

~0003580

caseydk (administrator)

Closing this in favor of the original 0001419

~0003581

opto (manager)

Last edited: 2014-08-07 00:11

View 3 revisions

I think it is related but not a duplicate.

The other bug deals with manually changing the dependent task to an earlier date.

This feature request deals with the automatic propagation of start times in the dependency algorithm which does not yet allow dates to be moved backwards in time.

One more idea on that: if times are moved backwards (which is good for future tasks), that probably should not be done to tasks already started or with start dates in the past?
Or maybe it should? If at a project review point, I want to adapt the project plan to the reality?

+Notes

-Issue History
Date Modified Username Field Change
2014-06-18 13:15 opto New Issue
2014-06-18 13:36 caseydk Project v3.2 Release => v4.0 Release (Planning)
2014-07-25 20:35 caseydk Severity minor => feature
2014-08-06 18:39 caseydk Relationship added duplicate of 0001419
2014-08-06 18:40 caseydk Note Added: 0003580
2014-08-06 18:40 caseydk Status new => closed
2014-08-06 18:40 caseydk Assigned To => caseydk
2014-08-06 18:40 caseydk Resolution open => duplicate
2014-08-07 00:08 opto Note Added: 0003581
2014-08-07 00:08 opto Status closed => feedback
2014-08-07 00:08 opto Resolution duplicate => reopened
2014-08-07 00:09 opto Note Edited: 0003581 View Revisions
2014-08-07 00:11 opto Note Edited: 0003581 View Revisions
2014-10-12 12:50 caseydk Target Version => 4.0
2016-12-26 10:25 caseydk Project v4.0 Release (Planning) => Pending Requests
+Issue History