2017-08-19 02:18 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001592v3.4 Release (Cleanup)Project Designerpublic2016-12-26 23:37
Reporteropto 
Assigned Tocaseydk 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusresolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0001592: can't set user priority (admin account in test installation)
Descriptionwe just solved that, what happened?
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0003575

caseydk (administrator)

I just tested against my master and I'm not seeing any issues. I tested the select all and individually selecting items.

~0003582

opto (manager)

I still can't set, nothing happens

to be sure that I am assigned, I created a task in projectdesigner and tried to set UP for that.

Maybe there is a bug in adding tasks in projectdesigner which then triggers this behaviour?

3.2 truely can do this.

~0003583

opto (manager)

Last edited: 2014-08-07 10:23

View 2 revisions

maybe UP is set but not diplayed?

~0003584

opto (manager)

Last edited: 2014-08-07 13:30

View 2 revisions

I just doublechecked the db. UP is correctly set.

But projectdesigner does not show UP, only a - sign for all tasks.
Doesn't that mean that the userid is wrong in the sql?

P shows either arrow up, down or space, but not - sign

(in FF)


for example, is correctly shown in my tasks

~0003588

opto (manager)

Last edited: 2014-08-13 09:16

View 2 revisions

why was this assigned to me? I think I fixed it already in 1530.


actually, it does set, but not display.

see email or:


do you really see user priorities in your projectdesigner?

if I understand the new code correctly, vw_projecttasks creates the task view, which then is actually done in gettasktree which collects the tasks.

This, just as pre bugfix 1530, does not get any user priority from the db, so it is clear that only a - is displayed - just as before my bugfix.

same for tasks

todo shows UP but gets tasks from one of the old functions.

Klaus

~0003624

caseydk (administrator)

You are correct that this is working as expected. I've attached a screencap from my project designer.

~0003666

opto (manager)

Last edited: 2014-10-09 04:33

View 2 revisions

sorry to say, but it is not fixed for wampserver and php 5.3 (I think).

Your screenshot further up actually shows Priority, not user priority. UP would be the - sign next to it.
As I wrote further up, the new function does not get UP from the db, so it cannot display, unless you changed that.

see note (0003588) (ca. 2 notes up) for fix

Klaus

~0003700

caseydk (administrator)

I've been digging on this one and added the field to the query. Fixed on master here:
https://github.com/web2project/web2project/commit/3f49f6c7a663ef4bd638b1a16359af096bb8e491

That said, I'm starting to not like User Priority at all.. because if you have three users who's priority do you show? How do you designate which is for which person?

~0003701

opto (manager)

to comment your last note:

projectdesigner shows my (=logged in) user priority or a minus sign for not applicable. Also, it allows to set my UP (only mine), and I think the text on the edit box is clear about that.

Somewhere in tasks, I can show and edit the UP for all users.
Each user's todo shows his/her individual UP.

This all makes total sense, because:

a low priority task gets high priority for the assigned user when it comes up for him to do it. Also, I can use UP to guide employees what to do first.

Even if the task has high UP fir the user doing it, its relative priority for the project context is not changed. In view of all other tasks, it is still low priority. So we wouldn't want to use priority for this.
But not for the team member actually working on it, for him (only), it has high priority at a certain point in time (otherwise he would never do it).
+Notes

-Issue History
Date Modified Username Field Change
2014-08-05 13:37 opto New Issue
2014-08-06 14:47 caseydk Note Added: 0003575
2014-08-06 14:47 caseydk Assigned To => opto
2014-08-06 14:47 caseydk Status new => feedback
2014-08-07 04:14 opto Note Added: 0003582
2014-08-07 04:14 opto Status feedback => assigned
2014-08-07 04:15 opto Note Added: 0003583
2014-08-07 10:23 opto Note Edited: 0003583 View Revisions
2014-08-07 13:28 opto Note Added: 0003584
2014-08-07 13:30 opto Note Edited: 0003584 View Revisions
2014-08-13 09:15 opto Assigned To opto => caseydk
2014-08-13 09:16 opto Note Added: 0003588
2014-08-13 09:16 opto Note Edited: 0003588 View Revisions
2014-08-16 20:02 caseydk File Added: Screen Shot 2014-08-16 at 10.01.52 PM.png
2014-08-16 20:04 caseydk Note Added: 0003624
2014-08-16 20:04 caseydk Status assigned => resolved
2014-08-16 20:04 caseydk Fixed in Version => 3.2
2014-08-16 20:04 caseydk Resolution open => no change required
2014-09-02 13:23 caseydk Fixed in Version 3.2 => 4.0
2014-10-08 09:20 caseydk Project v3.2 Release => v3.3 Release (Current)
2014-10-08 09:21 caseydk Target Version => 3.3
2014-10-08 09:21 caseydk Fixed in Version 4.0 => 3.3
2014-10-08 09:22 caseydk Status resolved => closed
2014-10-09 04:31 opto Note Added: 0003666
2014-10-09 04:31 opto Status closed => feedback
2014-10-09 04:31 opto Resolution no change required => reopened
2014-10-09 04:33 opto Note Edited: 0003666 View Revisions
2014-10-11 20:18 caseydk Status feedback => assigned
2014-10-19 11:59 caseydk Note Added: 0003700
2014-10-19 11:59 caseydk Status assigned => resolved
2014-10-19 11:59 caseydk Resolution reopened => fixed
2014-10-19 13:42 opto Note Added: 0003701
2014-10-19 13:42 opto Status resolved => feedback
2014-10-19 13:42 opto Resolution fixed => reopened
2014-11-21 21:38 caseydk Status feedback => resolved
2014-11-21 21:38 caseydk Resolution reopened => fixed
2016-12-26 23:37 caseydk Project v3.3 Release (Current) => v3.4 Release (Cleanup)
+Issue History