2017-05-25 01:38 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001625v3.3 Release (Current)Filespublic2014-10-08 09:21
Reporterchdrsto 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSDebianOS VersionTesting
Product Version 
Target Version3.3Fixed in Version3.3 
Summary0001625: Unable to upload documents of files
DescriptionI'm running fresh installed W2P 3.2 on a Debian Testing system. It's an Apache 2.4.10 with PHP 5.6.0 / MySQL 5.5.39 installed.

On this (fresh) installation it is not possible to use file module to upload any file nor document.

By pressing the save button I get a blank and empty page without having the file uploaded. I've also created a folder named 0 (zero) and checked the folder pemissions on file system level. All seems to be OK.

On log file i get some PHP warings (see attachment)
Steps To Reproduce1) Open upload file module
2) Attach a file (on Project or not)
3) Press save button
Additional InformationIve also requested information / support on W2P Support forum without success.
http://support.web2project.net/questions/1563/unable-to-upload-documents-or-files.html
TagsNo tags attached.
Attached Files
  • txt file icon LOG.txt (978 bytes) 1969-12-31 16:00 -
    [Wed Sep 24 10:49:15.392968 2014] [:error] [pid 5437] [client IP:59466] PHP Warning: include(/var/www/html/3.2/classes/w2p/Interfaces/Filesystem.class.php): failed to open stream: No such file or directory in /var/www/html/3.2/classes/w2p/web2project.php on line 31, referer: http://localhost/ppm/index.php?m=files&a=addedit&folder=0
    [Wed Sep 24 10:49:15.393013 2014] [:error] [pid 5437] [client IP:59466] PHP Warning: include(): Failed opening '/var/www/html/3.2/classes/w2p/Interfaces/Filesystem.class.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/html/3.2/classes/w2p/web2project.php on line 31, referer: http://localhost/ppm/index.php?m=files&a=addedit&folder=0
    [Wed Sep 24 10:49:15.393149 2014] [:error] [pid 5437] [client IP:59466] PHP Fatal error: Interface 'w2p_Interfaces_Filesystem' not found in /var/www/html/3.2/classes/w2p/FileSystem/Local.class.php on line 10, referer: http://localhost/ppm/index.php?m=files&a=addedit&folder=0
    txt file icon LOG.txt (978 bytes) 1969-12-31 16:00 +

-Relationships
+Relationships

-Notes

~0003664

opto (manager)

see forums:
from burnspot




I THINK I SOLVED IT (maybe). In my download from the W2P site, the "Filesystem.class.php" file appears like this: FileSystem.class.php....the "S" in system is capitalized. The error message refers to the file as having only the "F" capitalized. Once I renamed the file with only the capital "F", it worked. So far, I've tested with a file attached to a task and one that's not attached to anything...works fine.

~0003665

caseydk (administrator)

Fixed in development:
https://github.com/web2project/web2project/commit/653c7873cd1a0148240eaf857a258068d921969c
+Notes

-Issue History
Date Modified Username Field Change
2014-09-29 07:47 chdrsto New Issue
2014-09-29 07:47 chdrsto File Added: LOG.txt
2014-10-06 09:02 opto Note Added: 0003664
2014-10-06 09:36 caseydk Note Added: 0003665
2014-10-06 09:36 caseydk Status new => resolved
2014-10-06 09:36 caseydk Fixed in Version => 3.2
2014-10-06 09:36 caseydk Resolution open => fixed
2014-10-06 09:36 caseydk Assigned To => caseydk
2014-10-08 09:20 caseydk Project v3.2 Release => v3.3 Release (Current)
2014-10-08 09:21 caseydk Target Version => 3.3
2014-10-08 09:21 caseydk Fixed in Version 3.2 => 3.3
2014-10-08 09:21 caseydk Status resolved => closed
+Issue History