Anonymous Login
2019-01-17 05:00 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001641v3.4 Release (Current)User Adminpublic2019-01-03 12:53
Reportertbsgroup 
Assigned Tocaseydk 
PriorityurgentSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformUnixOSLinux UbuntuOS Version11.04
Product Version 
Target VersionFixed in Version 
Summary0001641: users cannot login except admin
DescriptionUsers cannot login after upgrade from 3.0 to 3.3
It shows "Login Failed"

No error on apache and php error log
TagsNo tags attached.
Attached Files

-Relationships
has duplicate 0001645closedcaseydk v3.3 Release Only default user admin can login. 
+Relationships

-Notes

~0003726

caseydk (administrator)

Have you tried resetting passwords?

~0003727

caseydk (administrator)

Last edited: 2014-12-09 11:22

View 2 revisions

Alternatively, do any of the Roles have permissions assigned?

~0003730

tbsgroup (reporter)

Yes, try to reset the password using admin account and change Roles to other roles.

I've test by creating a new user and assign a role, the new user can login normally.

~0003731

caseydk (administrator)

So it sounds like this was just new users lacking a Role?

~0003732

tbsgroup (reporter)

No. New users created are fine.
Only existing users except admin cannot login

~0003740

tbsgroup (reporter)

The new installation have same problem now, new user created cannot login.

~0003742

thhewebmaster (reporter)

I had the same problem with a username containig a dot ( . )

When I created another user without the dot, it worked
The I changed the username with the dot to a name without the dot (had to do that using PHPMuAdmin), after that the user could log in

~0003743

densodave (reporter)

Take a look at <w2proot>/classes/w2p/Core/CAppUI.class.php

Edit line 789
change it from
    $user_id = $auth->userId();
to
    $user_id = $auth->userId($username):

This fixed the problem for me. I found the solution in a post by mhillsmt on Feb 4.
http://support.web2project.net/questions/1492/ldap-auth-w2p-user-account-is-created-in-backend-b.html

The post is specific to LDAP authentication, but seems to affect all authenticators other than the system default SQL.

~0003745

cedricj (reporter)

Hi all,

I've the same problem : since upgrading from v.3.0.0-rc1 to the last version, users with a login containing a dot (.) cannot log into web2project.

Only the admin account (so, without a dot in username) can.

For information, I don't use LDAP authentication.

The solution previously proposed (edit line 789 from file "<w2proot>/classes/w2p/Core/CAppUI.class.php") couldn't fix the problem.

Any idea ?

Thanks.

~0003746

caseydk (administrator)

I've tweaked the filter to allow periods in usernames here:

https://github.com/web2project/web2project/commit/e787d0beab29b4190eb7219dac6a36bcddbe68a7

~0003930

caseydk (administrator)

In the 31 Dec 2018 release: http://docs.web2project.net/release-notes/3.4.html
+Notes

-Issue History
Date Modified Username Field Change
2014-12-01 02:52 tbsgroup New Issue
2014-12-06 13:07 caseydk Note Added: 0003726
2014-12-06 13:07 caseydk Assigned To => caseydk
2014-12-06 13:07 caseydk Status new => feedback
2014-12-09 11:21 caseydk Note Added: 0003727
2014-12-09 11:22 caseydk Note Edited: 0003727 View Revisions
2014-12-12 01:11 tbsgroup Note Added: 0003730
2014-12-12 01:11 tbsgroup Status feedback => assigned
2014-12-12 10:41 caseydk Note Added: 0003731
2014-12-14 22:48 tbsgroup Note Added: 0003732
2015-01-21 19:02 tbsgroup Note Added: 0003740
2015-01-29 22:11 caseydk Relationship added has duplicate 0001645
2015-02-08 07:12 thhewebmaster Note Added: 0003742
2015-02-17 11:04 densodave Note Added: 0003743
2015-03-19 02:44 cedricj Note Added: 0003745
2015-04-10 22:44 caseydk Note Added: 0003746
2015-04-10 22:44 caseydk Status assigned => resolved
2015-04-10 22:44 caseydk Fixed in Version => 3.3
2015-04-10 22:44 caseydk Resolution open => fixed
2016-12-26 23:37 caseydk Project v3.3 Release => v3.4 Release (Current)
2019-01-03 12:53 caseydk Note Added: 0003930
2019-01-03 12:53 caseydk Status resolved => closed
+Issue History