Anonymous Login
2019-10-14 21:23 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000178v4.0 Release (Planning)Core Infrastructurepublic2016-12-29 10:16
Reportercaseydk 
Assigned Tocaseydk 
PrioritylowSeverityminorReproducibilityalways
StatusacknowledgedResolutionfixed 
Product Version 
Target Version4.0Fixed in Version4.0 
Summary0000178: Convert to the PSR Coding Standard
DescriptionThis will be updated to respect the PSRs instead of PEAR.
Additional InformationThis used to be the PEAR coding standard but has now been changed to PSR as of March 2014.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001639

Pierre (reporter)

I don't know if this is the right place to discuss this, but just seeing this standard suggests to place the opening brackets at the end of the line makes my stomach turn inside out. :-) (I fell either not do it or don't enforce it)
Personally I also don't like tab stops of 4, but prefer 2 since it separates it good enough while more code is visible. (here there must be some standard)

What I find more important is commenting code and the more the better. Being somewhat consistent to how variables are named, global and local. Use meaningful text for function and variables, not x71_d.

~0001643

caseydk (administrator)

I use tab stops of 4 but since most editors will let you configure that one, it's not a huge problem.

PEAR is handy because most of the tools - including IDE's - know how to read the standard and comments that follow it. We get code completion, static analysis, etc almost for free.

Regardless, this is a long term plan and we're working under the basis of "if you touch something, clean it up." As long as it's more legible for the next guy, we win. :)

~0003271

caseydk (administrator)

This has been updated to use the PSR standards, specifically PSR-1.

~0003636

caseydk (administrator)

Done:
https://github.com/web2project/web2project/commit/d0d200d1cdc8871a710b0ac1a291918fef9e5364

~0003837

caseydk (administrator)


I'm changing this issue to acknowledged.

While it's resolved in the v4.0 development branch. That is going to be reviewed commit by commit and merged into a new development branch over the next couple months.
+Notes

-Issue History
Date Modified Username Field Change
2009-06-07 21:18 caseydk New Issue
2009-06-14 05:38 caseydk Priority normal => low
2009-08-03 04:08 caseydk Project v1.1 Release (Closed) => Pending Requests
2009-12-08 11:50 caseydk Project Pending Requests => v1.3 Release (Closed)
2010-01-18 12:55 caseydk Project v1.3 Release (Closed) => v2.0 Release (Closed)
2010-05-29 22:08 caseydk Project v2.0 Release (Closed) => Pending Requests
2010-06-11 06:01 caseydk Project Pending Requests => v2.1 Release (Closed)
2010-09-04 22:26 caseydk Project v2.1 Release (Closed) => v2.4 Release (Closed)
2011-02-17 08:53 Pierre Note Added: 0001639
2011-02-17 09:44 caseydk Note Added: 0001643
2011-06-07 22:21 caseydk Project v2.4 Release (Closed) => Pending Requests
2011-08-09 13:12 caseydk Project Pending Requests => v4.0 Release (Planning)
2014-01-21 17:57 caseydk Target Version => 4.0
2014-03-13 22:20 caseydk Category General => Calendar
2014-03-13 22:20 caseydk Summary Convert to the PEAR Coding Standard => Convert to the PSR Coding Standard
2014-03-13 22:20 caseydk Description Updated View Revisions
2014-03-13 22:20 caseydk Additional Information Updated View Revisions
2014-03-27 09:46 caseydk Note Added: 0003271
2014-08-16 18:59 caseydk Category Calendar => Core Infrastructure
2014-08-29 22:53 caseydk Note Added: 0003636
2014-08-29 22:53 caseydk Status new => resolved
2014-08-29 22:53 caseydk Fixed in Version => 4.0
2014-08-29 22:53 caseydk Resolution open => fixed
2014-08-29 22:53 caseydk Assigned To => caseydk
2016-12-29 10:16 caseydk Status resolved => acknowledged
2016-12-29 10:16 caseydk Note Added: 0003837
+Issue History