Anonymous Login
2019-12-14 21:44 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000183v2.3 Release (Closed)[All Projects] Generalpublic2011-03-24 09:54
Reportersweatje 
Assigned Tocaseydk 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version2.3 
Summary0000183: Change order of projects in multi-project Gantt chart
DescriptionWhen you click on the "This Project is Part of the Following Multi-Project Structure:" link, the list of projects appears in the correct sequence, but the Gantt chart displays in a different order.

I believe the order in the Gantt chart has to do with when the project was created. If you are viewing a multi-project Gantt, I believe the order of tasks should be:
a) parent projects first
b) dependent task in order
c) task by start date

I think this manifest itself most for me when I assigned an older project to a newer nested parent project, and yet the older project displays first on the Gantt chart.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001417

caseydk (administrator)

The order is currently alphabetical. Further, since this report was submitted, we've implemented "Token Tasks" to represent subprojects. For the purposes of this Gantt Chart, all Token Tasks should be omitted in favor of displaying the actual projects.

~0001625

caseydk (administrator)

Adjusted the order to use start/end date instead of project name, it keeps the nested Gantt charts similar conceptually to regular Gantt charts;

Resolved in r1639 & 1640;
+Notes

-Issue History
Date Modified Username Field Change
2009-06-09 05:37 sweatje New Issue
2010-05-04 18:21 caseydk Category Projects => Gantt Chart Generation
2010-12-08 12:36 caseydk Project Pending Requests => v2.3 Release (Closed)
2010-12-08 12:38 caseydk Note Added: 0001417
2011-02-13 21:51 caseydk Note Added: 0001625
2011-02-13 21:51 caseydk Status new => resolved
2011-02-13 21:51 caseydk Resolution open => fixed
2011-02-13 21:51 caseydk Assigned To => caseydk
2011-03-24 09:53 caseydk Fixed in Version => 2.3
2011-03-24 09:54 caseydk Status resolved => closed
+Issue History