Anonymous Login
2019-02-21 12:20 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000193v1.1 Release (Closed)[All Projects] Generalpublic2009-09-09 22:44
Reporterpacho 
Assigned Tocaseydk 
PriorityimmediateSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version1.1 
Summary0000193: Special Characters (i.e. German 'Umlaute') are not displayed correctly for projects
DescriptionSpecial characters are not saved/ retrieved and displayed correctly for porjects. This is especially cumbersome when using German 'Umlaute' or other special characters like $, $, etc. (they are displayed as black squares with a question mark)
Additional InformationIt seems that the same special character is saved to the database differently, depending on the entity that is worked on. E.g. for a company the value for 'ü' is different from the value for 'ü' when saved for a project. The behaviour for companies is correct!

We also tried several different settings for PHP.ini, setting all string charactersets to UTF-8 (which should usually work). We also looked at the http header information which seems to be correct using UTF-8. So it seems that something is happening programmatically when writing string/text content to the db and retrieving it again for display/change.

Attached 2 screenshots.
TagsNo tags attached.
Attached Files

-Relationships
related to 0000085closedpedroa v1.2 Release (Closed) Danish characters not shown properly 
related to 0000051closedpedroa v1.2 Release (Closed) accentuated caracters don't show up everywere 
related to 0000208closedcaseydk v1.1 Release (Closed) Improper UTF-8 decoding in project viewer title bar 
related to 0000209closedcaseydk v1.1 Release (Closed) Accents incorrectly UTF-8 decoded when downloading files 
related to 0000207closedcaseydk v1.1 Release (Closed) Make 3rd party modules menu titles translatable w/o altering core wp2 inc files 
related to 0000206closedcaseydk v1.1 Release (Closed) Missing abbreviations in en/system.inc 
+Relationships

-Notes

~0000304

eureka (reporter)

Currently, web2project does not fully support UTF-8 and it seems that this is not a priority. In the meantime you can follow these instructions: http://forums.web2project.net/viewtopic.php?t=152

~0000305

caseydk (administrator)

It *is* a priority, just not something that we can test with the people we currently have.. whom are using English for all input.

Now that we have a few others in the mix - you two aren't the only ones we've heard from - I am scheduling this for the v1.1 release which should be the first week of September.

Obviously we need help to make sure this is properly implemented and tested. :)

~0000308

pacho (reporter)

Anything new here or is there a possibility of getting a pre-release (for testing)?
What are the implications if we enter data right now (with the version as is) especially for tasks and projects? Will we need to re-enter the data once the update is available or will the data just be displayed correctly?

~0000309

eureka (reporter)

no, you wil not need to re-enter data, you just will need to convert them with "alter table"

~0000310

caseydk (administrator)

Alright guys, this evening I added some more Unit Tests for the translation module itself. Now that I have a better grasp on that, I'm going to write some tests for this code and start integrating it into core later this week. Feel free to follow along in the commit logs - http://web2project.net/mailman/listinfo/w2p-commit_web2project.net

You have not been forgotten. :)

~0000314

MiraKlim (reporter)

I have had the same problem with czech accent characters. I applied the solution proposed by Eureka http://forums.web2project.net/viewtopic.php?t=152.
As I was lazy I applied changes mentioned under 2,3,6,7,8,9. I also didnn't applied the replacement of strlen to w2PUTF8strlen.
This solved the problem for me except gantt charts. The problem in gantt charts is in fonts, I think.
I cannot agree that after convert all data will be in correct format. I had to re-entrer some data. Not sure why.

~0000315

caseydk (administrator)

I've started integrating these changes piece by piece... you can see them in r487-489. They're not done but well underway.

~0000316

eureka (reporter)

Last edited: 2009-07-07 12:35

All changes must be applied including w2PUTF8strlen because utf-8 characters occupies 1 to 4 bytes.

Sometimes, characters have been stored in the database in their entities form, in which case it is necessary to re-enter them.

Gantt charts display correctly for me, even with french accented characters.

~0000327

caseydk (administrator)

Applied another round of updates in r505;

This covers through step 9 here - http://forums.web2project.net/viewtopic.php?p=1597#1597

~0000330

eureka (reporter)

Hello caseydk,

Thank you for these changes :)

Do you plan to implement step 10 and those in this message: http://forums.web2project.net/viewtopic.php?p=1623#1623 ?

~0000344

egemme (reporter)

Hi caseydk,

Are you the maintainer of the reports module? If so, could you add to the list to review all the PDF generation since it messes-up all accents. This problem takes it's origin from dP. This is not a very high priority since we never used reports because of this problem.

It seems you now have a good team for foreign languages building which is good news for us and w2p in general. I'm a french canadian from Quebec and could provide great help for testing and filling-up french translations. I'm happy eureka provided you much of the latest translations... I was about to complete it and he's been faster than me by one day :( Just don't hesitate to utilize us. I'm currently plugged in SVN trunk and check news daily. Just tell me how do you prefer us to sent translations because I completed reports and resources, but also helpdesk and timecard 3rd party modules.

~0000347

MiraKlim (reporter)

I have tested latest nightly snaposhot (r518) and I found no problem with czech accent characters. Seems to be working :-)

~0000349

eureka (reporter)

Normal ! But I insist, caseydk must replace some strlen and substr by w2PUTF8strlen and w2PUTF8substr respectively because utf-8 characters are multi-bytes, if not we will have problems.

~0000393

caseydk (administrator)

eureka, et al,

The last of those changes have been made (r565), please start testing away. :)

~0000409

caseydk (administrator)

Since we're trying to get feedback and close out bugs for v1.1 - estimated 08 Sept release - I need some help on this one.... *help*!? Is it working as expected? If not, what needs to be changed?


And guidance/info would be appreciated on http://bugs.web2project.net/view.php?id=208 and http://bugs.web2project.net/view.php?id=209

~0000410

pacho (reporter)

So far we have not encountered any further problems. Looks good to me! :)

~0000416

caseydk (administrator)

Great to hear. Can anyone take a look at 0000208 and 0000209 (linked in my prev comment) to see if this resolves those? We're 6 days from v1.1 and we *need* to know what is or isn't covered.

Besides, then I get to formally thank you guys in the Release Notes. ;)

~0000421

caseydk (administrator)

Others have stated this is fixed, I haven't been able to reproduce it lately.

~0000467

caseydk (administrator)

Closed for release.
+Notes

-Issue History
Date Modified Username Field Change
2009-06-19 02:01 pacho New Issue
2009-06-19 02:01 pacho File Added: screens.rar
2009-06-21 00:07 eureka Note Added: 0000304
2009-06-21 12:45 caseydk Note Added: 0000305
2009-06-21 12:45 caseydk Project v1.0 Release (Closed) => v1.1 Release (Closed)
2009-06-21 12:45 caseydk Status new => assigned
2009-06-21 12:45 caseydk Assigned To => caseydk
2009-06-21 12:49 caseydk Severity major => block
2009-06-22 04:52 caseydk Relationship added related to 0000112
2009-06-22 04:52 caseydk Relationship added related to 0000085
2009-06-22 04:52 caseydk Relationship added related to 0000051
2009-06-22 04:53 caseydk Relationship deleted related to 0000112
2009-07-01 01:28 pacho Note Added: 0000308
2009-07-01 11:22 eureka Note Added: 0000309
2009-07-01 22:16 caseydk Note Added: 0000310
2009-07-01 22:17 caseydk Priority normal => urgent
2009-07-07 11:44 MiraKlim Note Added: 0000314
2009-07-07 12:13 caseydk Note Added: 0000315
2009-07-07 12:21 eureka Note Added: 0000316
2009-07-07 12:35 eureka Note Edited: 0000316
2009-07-07 21:19 caseydk Priority urgent => immediate
2009-07-09 19:07 caseydk Note Added: 0000327
2009-07-12 10:12 eureka Note Added: 0000330
2009-07-18 07:02 caseydk Relationship added related to 0000208
2009-07-18 07:02 caseydk Relationship added related to 0000209
2009-07-18 07:02 caseydk Relationship added related to 0000207
2009-07-18 07:02 caseydk Relationship added related to 0000206
2009-07-19 05:54 egemme Note Added: 0000344
2009-07-22 12:01 MiraKlim Note Added: 0000347
2009-07-22 12:27 eureka Note Added: 0000349
2009-08-16 16:31 caseydk Note Added: 0000393
2009-08-16 16:31 caseydk Status assigned => feedback
2009-08-31 21:44 caseydk Note Added: 0000409
2009-08-31 22:44 pacho Note Added: 0000410
2009-09-02 21:36 caseydk Note Added: 0000416
2009-09-08 22:50 caseydk Status feedback => resolved
2009-09-08 22:50 caseydk Fixed in Version => 1.1
2009-09-08 22:50 caseydk Resolution open => fixed
2009-09-08 22:50 caseydk Note Added: 0000421
2009-09-09 22:44 caseydk Status resolved => closed
2009-09-09 22:44 caseydk Note Added: 0000467
+Issue History