Anonymous Login
2019-12-06 17:22 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000194v1.1 Release (Closed)[All Projects] Generalpublic2009-09-09 22:44
Reportercaseydk 
Assigned Totrevormorse 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version1.1 
Summary0000194: Task Log Update vs Create vs Log Date
DescriptionWhen a Task Log is created, there is currently a task_log_date which is being used alternately for a date created/logged and a task log date. From a data validation point of view, this should be broken into three fields:

* A date representing the create date of the log itself. Upon database insert, this should be set to now() and never changed again.

* A date representing the update date of the log itself. Whenever the row is edited (including at insert), this value should be set to now().

* A date representing the actual date of the log regardless of and independent from the above dates. Since the time portion of this datetime is not relevant, it could be simplified to a simple date.

For example, if a log is created for work performed yesterday, the first two dates would be now() while the final date would be set to yesterday.
TagsNo tags attached.
Attached Files

-Relationships
related to 0000236closedtrevormorse Created and Updated fields not updated. 
+Relationships

-Notes

~0000413

caseydk (administrator)

I think you (Trevor) may already have this one wrapped up but in that case it should be closed anyway.

~0000415

trevormorse (developer)

Fixed this by adding a task_log_created and task_log_updated field to the task_log table. As well the task_log_date was converted to a date field.

~0000468

caseydk (administrator)

Closed for release.
+Notes

-Issue History
Date Modified Username Field Change
2009-06-24 15:09 caseydk New Issue
2009-06-24 15:17 caseydk Description Updated
2009-07-07 21:19 caseydk Priority normal => low
2009-08-15 04:29 caseydk Relationship added related to 0000236
2009-09-02 09:25 caseydk Status new => assigned
2009-09-02 09:25 caseydk Assigned To => trevormorse
2009-09-02 09:25 caseydk Note Added: 0000413
2009-09-02 14:37 trevormorse Note Added: 0000415
2009-09-02 14:37 trevormorse Status assigned => resolved
2009-09-02 14:37 trevormorse Resolution open => fixed
2009-09-09 22:44 caseydk Status resolved => closed
2009-09-09 22:44 caseydk Note Added: 0000468
2009-09-09 22:44 caseydk Fixed in Version => 1.1
+Issue History