Anonymous Login
2022-07-02 19:20 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000200v1.1 Release (Closed)[All Projects] Generalpublic2009-09-09 22:39
ReporterMiraKlim 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityN/A
StatusclosedResolutionduplicate 
Product Version 
Target VersionFixed in Version1.1 
Summary0000200: Active links in description fields
DescriptionIt would be nice if http links inserted into description/summary fields for project/task/logs etc are displayed as links instead of pure text. To allow this function linkLinks (see additional info) can be used. I think it can be added to main_functions.php. I am currently using this in helpdesk module and for better integeration with task and files module I need it in main_functions.php


Additional Information
function linkLinks($data){
    $data = strip_tags($data);
    $search_email = '/([\w-]+([.][\w_-]+){0,4}[@][\w_-]+([.][\w-]+){1,3})/';
    $search_http = '/(http(s)?:\/\/[^\s]+)/i';
    $data = preg_replace($search_email,"<a href=\"mailto:$1\">$1</a>",$data);
    $data = preg_replace($search_http,"<a href=\"$1\" target=\"_blank\">$1</a>",$data);
    return $data;
}
TagsNo tags attached.
Attached Files

-Relationships
duplicate of 0000089closedcaseydk v1.3 Release (Closed) Automatically parse URLs found in text areas 
+Relationships

-Notes

~0000329

caseydk (administrator)

Marked 'resolved' in favor of the earlier issue.

~0000438

caseydk (administrator)

Closed for release.
+Notes

-Issue History
Date Modified Username Field Change
2009-07-08 11:52 MiraKlim New Issue
2009-07-12 05:03 caseydk Project Pending Requests => v1.1 Release (Closed)
2009-07-12 05:08 caseydk Relationship added duplicate of 0000089
2009-07-12 05:08 caseydk Duplicate ID 0 => 89
2009-07-12 05:08 caseydk Status new => resolved
2009-07-12 05:08 caseydk Resolution open => duplicate
2009-07-12 05:08 caseydk Assigned To => caseydk
2009-07-12 05:08 caseydk Note Added: 0000329
2009-09-09 22:39 caseydk Status resolved => closed
2009-09-09 22:39 caseydk Note Added: 0000438
2009-09-09 22:39 caseydk Fixed in Version => 1.1
+Issue History