Anonymous Login
2019-09-16 10:01 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000206v1.1 Release (Closed)[All Projects] Generalpublic2009-09-09 22:42
Reporteregemme 
Assigned Tocaseydk 
PrioritynormalSeveritytextReproducibilityalways
StatusclosedResolutionwon't fix 
Product Version 
Target VersionFixed in Version1.1 
Summary0000206: Missing abbreviations in en/system.inc
DescriptionThere are several missing abbreviations in en/system.inc preventing complete translation of system configuration module.
TagsNo tags attached.
Attached Files

-Relationships
related to 0000193closedcaseydk Special Characters (i.e. German 'Umlaute') are not displayed correctly for projects 
+Relationships

-Notes

~0000357

caseydk (administrator)

Which ones? Can you attach a diff of the fixed file or a list of the ones that need to be added?

~0000358

egemme (reporter)

When viewing w2P in english, these are
check_task_empty_dynamic_title
gacl_group_title
gacl_cache_title
gacl_expire_title
gacl_cache_dir_title
gacl_timeout_title

note that the corresponding tooltips abbreviations are also missing.

And btw, the check_task_empty_dynamic_title seems lost on top of the list. Is it at the right place? Shouldn't it be in the task group?

~0000359

caseydk (administrator)

While those definitely *aren't* found in the translation files, I can't find where they're used *anywhere* in the system... not even in the database creation scripts. Suggestions on where in the code or which screens I can see this one?

~0000362

egemme (reporter)

Hi, it's normal since config items are all softcoded in config table in the DB. Therefore, is it possible I got more items in my config table than yours? Always keep in mind that I migrated from dP ! I included two html outputs: config and config_list. I presume a cleanup must be done to these tables to match new w2P requirements.

~0000363

caseydk (administrator)

Thanks, I use a fresh install and test conversion using a dP 2.1.2 installation.

Thanks for the info though, I'll check it out.

~0000365

egemme (reporter)

In dP, permission.class.php refered to several gacl config items as per this excerpt

    function dPacl($opts = null) {
        global $db;
        
        if (!(is_array($opts))) {
            $opts = array();
        }
        $opts['db_type'] = dPgetConfig('dbtype');
        $opts['db_host'] = dPgetConfig('dbhost');
        $opts['db_user'] = dPgetConfig('dbuser');
        $opts['db_password'] = dPgetConfig('dbpass');
        $opts['db_name'] = dPgetConfig('dbname');
        $opts['caching'] = dPgetConfig('gacl_cache', false);
        $opts['force_cache_expire'] = dPgetConfig('gacl_expire', true);
        $opts['cache_dir'] = dPgetConfig('gacl_cache_dir', '/tmp');
        $opts['cache_expire_time'] = dPgetConfig('gacl_timeout', 600);
        $opts['db'] = $db;

w2P just doesn't have these. They must be defaulted everywhere in the code. I don't mind removing them. It might also be nice to have the conversion script do some sort of cleanup, but this is really not urgent 'cause these extra config rows don't hurt at all. This just make config screen a bit ackward.

~0000367

caseydk (administrator)

Thanks for the info... I'm going to move this to "Won't Fix' as they're configuration options that don't get used anymore. If you can let me know what version of dotProject you converted from, we can make sure to remove those values upon conversion.

Thanks.

~0000454

caseydk (administrator)

Closed for release.
+Notes

-Issue History
Date Modified Username Field Change
2009-07-17 18:35 egemme New Issue
2009-07-18 07:02 caseydk Relationship added related to 0000193
2009-07-28 10:48 caseydk Note Added: 0000357
2009-07-28 10:48 caseydk Status new => feedback
2009-07-28 11:45 egemme Note Added: 0000358
2009-07-28 21:03 caseydk Note Added: 0000359
2009-07-29 04:11 egemme Note Added: 0000362
2009-07-29 04:12 egemme File Added: config.html
2009-07-29 04:12 egemme File Added: config_list.html
2009-07-29 05:46 caseydk Note Added: 0000363
2009-07-30 17:17 egemme Note Added: 0000365
2009-07-30 19:57 caseydk Status feedback => resolved
2009-07-30 19:57 caseydk Resolution open => won't fix
2009-07-30 19:57 caseydk Assigned To => caseydk
2009-07-30 19:57 caseydk Note Added: 0000367
2009-09-09 22:42 caseydk Status resolved => closed
2009-09-09 22:42 caseydk Note Added: 0000454
2009-09-09 22:42 caseydk Fixed in Version => 1.1
+Issue History