2017-11-20 05:30 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000208v1.1 Release (Closed)[All Projects] Generalpublic2009-09-09 22:43
Reporteregemme 
Assigned Tocaseydk 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version1.1 
Summary0000208: Improper UTF-8 decoding in project viewer title bar
DescriptionUTF-8 works almost perfectly in w2P, as it did in dP - this might be sarcastic since I hate UTF-8 which works good only with non accented languages ;)

It seems UTF-8 french accents go pretty good so far, but for an unknown reason, uppercase accented (e.g. É, À) caracters struggle a bit, but only on the project title stripe in the project details. See the screen shots included.

I remember I was so fed up of sparse UTF-8 behavior in dP that I finally converted it to ISO-8859-1. Wished to avoid this move this time !


TagsNo tags attached.
Attached Files

-Relationships
related to 0000193closedcaseydk Special Characters (i.e. German 'Umlaute') are not displayed correctly for projects 
+Relationships

-Notes

~0000340

eureka (reporter)

Last edited: 2009-07-18 02:12

This suggestion : http://bugs.web2project.net/view.php?id=112
should solve this problem

Caution : take care of this commit : http://forums.web2project.net/viewtopic.php?t=890 , this suggestion must be adapted

~0000341

egemme (reporter)

Last edited: 2009-07-18 05:01

Your suggestion doesn't hurt, but doesn't help neither. Made the change w/o any relief. My problem is not related to crumbs but rather the project name in the title of the first table, right over the project details.

When I look to the code, It seems vw_projects.php loads the project data differently compared to view.php:

vw_projects uses the loadList method from the DBQuery class while view.php gets data around a loadObject method as found in the fullLoad method of the CProject class.

I'm not a PHP expert, and OO neither, but I see that loadObject does some extra steps to the hash list rather than a simple fetchRow in order to bind the data to an exportable object. This might destroy the UTF-8 encoding coming from the database. But why just for uppercase accents and not the other.

~0000342

egemme (reporter)

Finally been able to fix this behavior at the data level by editing the project, and typing over the messed-up accent and updating. Now the project name shows correcly everywhere.

However, the loadObject vs loadList difference in behavior still sting my curiosity because when the display problem existed only partialy depending on the use of one or another.

Since your already have plenty of things to do, you may put this request far away ahead.

~0000343

eureka (reporter)

Oh sorry, my note above was for issue 0000207 !

~0000424

caseydk (administrator)

Fixed as a result of the changes included for 0000193

~0000461

caseydk (administrator)

Closed for release.
+Notes

-Issue History
Date Modified Username Field Change
2009-07-17 18:58 egemme New Issue
2009-07-17 18:58 egemme File Added: Projects.jpg
2009-07-18 02:04 eureka Note Added: 0000340
2009-07-18 02:12 eureka Note Edited: 0000340
2009-07-18 05:00 egemme Note Added: 0000341
2009-07-18 05:01 egemme Note Edited: 0000341
2009-07-18 05:09 egemme Note Added: 0000342
2009-07-18 07:02 caseydk Relationship added related to 0000193
2009-07-18 07:49 eureka Note Added: 0000343
2009-09-08 23:12 caseydk Status new => resolved
2009-09-08 23:12 caseydk Fixed in Version => 1.1
2009-09-08 23:12 caseydk Resolution open => fixed
2009-09-08 23:12 caseydk Assigned To => caseydk
2009-09-08 23:12 caseydk Note Added: 0000424
2009-09-09 22:43 caseydk Status resolved => closed
2009-09-09 22:43 caseydk Note Added: 0000461
+Issue History