Anonymous Login
2019-08-25 21:38 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000209v1.1 Release (Closed)[All Projects] Generalpublic2009-09-09 22:43
Reporteregemme 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version1.1 
Summary0000209: Accents incorrectly UTF-8 decoded when downloading files
DescriptionWhen downloading a file, if filename contains french accents, there not decoded in the resulting name causing a complete mess when checking out and back in files. This annoyance has always been present from the ealiest days of dP.

As mentionned elsewhere in Mantis, UTF-8 finally made me mad and converted all my dP data to ISO-8859-1 and finally got rid of all these accents annoyances and got a peace of mind. However, I know UTF-8 is the facto standard for modern web apps :( I wouldn't say it's major however since this is really not a show stopper, but this put a little shade on the whole package from my own perspective (I like things being sleek and nice from top to bottom).

Continue your great work since you've enhanced dP 1000% so far. I'm grinchy a bit, but I'm not a bad guy neither ;)
TagsNo tags attached.
Attached Files

-Relationships
related to 0000193closedcaseydk Special Characters (i.e. German 'Umlaute') are not displayed correctly for projects 
+Relationships

-Notes

~0000352

egemme (reporter)

I've found that in fileviewer.php adding a utf8_decode to 'file_name' when building the mime fixes my problem. Obviously, this may not be suitable on every client platforms.

~0000425

caseydk (administrator)

Resolved due to the changes included in 0000193.

~0000462

caseydk (administrator)

Closed for release.
+Notes

-Issue History
Date Modified Username Field Change
2009-07-17 19:22 egemme New Issue
2009-07-18 07:02 caseydk Relationship added related to 0000193
2009-07-25 05:30 egemme Note Added: 0000352
2009-09-08 23:14 caseydk Status new => resolved
2009-09-08 23:14 caseydk Fixed in Version => 1.1
2009-09-08 23:14 caseydk Resolution open => fixed
2009-09-08 23:14 caseydk Assigned To => caseydk
2009-09-08 23:14 caseydk Note Added: 0000425
2009-09-09 22:43 caseydk Status resolved => closed
2009-09-09 22:43 caseydk Note Added: 0000462
+Issue History