Anonymous Login
2019-11-15 04:13 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000229Pending RequestsTranslationspublic2014-06-22 21:10
ReporterKrzysztofKamil 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusfeedbackResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0000229: Issue with saving my version of locale via Language Support - applies to common.inc
DescriptionI use this feature to make Polish locale, what it's really great thing, guys.

But if I'm changing sth in common.inc and saving this, it appears problem - w2P doesn't read this file correctly and whole text in system has these bad, bad appended warning string "^".

I know what causes this.
When locale is saving, escape signs in abbreviation part weren't saved. I opened common.inc in Notepad and fixed it. But if next time I'll would like to correct sth, I've to use open file via FTP ;/
Generally it's not a problem but my translators sometimes can't update locale using Language Support.
Additional Information"Bad lines" in common.inc (with required escape signs)
Line 122: 'Include Children (doesn\'t apply to delete or move within the same project)'=>'Zawiera pochodne (nie dotyczy usuwania lub przesuwania w obr?bie projektu)',
Line 279: 'User\'s projects'=>'Projekty u?ytkownika',
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000675

caseydk (administrator)

So the problem is that the escape symbols aren't being saved so it messes up the rest of the file and the world ends... or something like that?

Can you give me a few examples of translated words? I'd like to mimic your process as closely as possible.

~0000676

KrzysztofKamil (reporter)

Yes. But it isn't related with specific words.
Just if saving file i.e. common.inc, all escape symbols in given english string disappears.
In common.inc there're of them. As I pointed above, escape symbols have to be in:
"Include Children (doesn\'t apply to delete or move within the same project)=>"
"'User\'s projects'=>"
Some function probably "forgets" about saving escape symbols from memory to file.
Without escape symbols in translated text (Polish in my case) displaying translation is working.

~0000688

caseydk (administrator)

I still haven't been able to reproduce this one. What version of PHP are you using?

(And yes, I'm trying to make sure this is ready for the v1.2.1 release next week.)

~0000689

KrzysztofKamil (reporter)

PHP 5.3.

~0000690

caseydk (administrator)

Hmmm.. me too. I even used your exact "Include Children..." example directly.

Could you (privately!) send me the results of running phpinfo()? There has to be a configuration thing that I'm missing.

Thanks.
+Notes

-Issue History
Date Modified Username Field Change
2009-08-05 15:21 KrzysztofKamil New Issue
2009-09-08 23:39 caseydk Project v1.1 Release (Closed) => Pending Requests
2009-12-20 05:48 caseydk Note Added: 0000675
2009-12-20 05:49 caseydk Project Pending Requests => v1.2 Release (Closed)
2009-12-20 05:55 KrzysztofKamil Note Added: 0000676
2009-12-24 21:32 caseydk Note Added: 0000688
2009-12-24 21:32 caseydk Status new => feedback
2009-12-25 09:21 KrzysztofKamil Note Added: 0000689
2009-12-25 11:05 caseydk Note Added: 0000690
2010-01-05 20:02 caseydk Project v1.2 Release (Closed) => Pending Requests
2014-06-22 21:10 caseydk Category General => Translations
2014-06-22 21:10 caseydk Product Version 1.1 =>
2014-06-22 21:10 caseydk Additional Information Updated View Revisions
+Issue History