2017-11-20 05:28 PST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000233v1.1 Release (Closed)[All Projects] Generalpublic2009-09-09 22:44
Reportereureka 
Assigned Tocaseydk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Product Version1.1 
Target VersionFixed in Version1.1 
Summary0000233: Rev 558 : install with dotproject conversion errors
DescriptionI got these errors during the installation of revision 558 of web2project:

Step 2: Update Database & Write Configuration
There were 12 errors in the system update.
Duplicate column name 'session_user'
Duplicate key name 'idx_cfv_id'
Duplicate column name 'file_folder'
Table 'file_folders' already exists
Table 'project_designer_options' already exists
Table 'resources' already exists
Table 'resource_tasks' already exists
Table 'resource_types' already exists
Can't DROP 'sysval_title'; check that column/key exists
Data truncated for column 'contact_department' at row 6
BLOB/TEXT column 'contact_department' used in key specification without a key length
Duplicate entry 'reset_memory_limit' for key 'config_name'
Note: Errors noting 'Duplicate entry', 'Table already exists', or 'Unknown table' may not be problems. It's possible that your dotProject database was not the version it claimed to be.
Additional InformationMy version of dotproject is 2.1.2.
TagsNo tags attached.
Attached Files

-Relationships
related to 0000230closedcaseydk Rev 555 : install with dotproject conversion errors 
+Relationships

-Notes

~0000388

caseydk (administrator)

Could you send me a snapshot of your pre-conversion database? Thanks.

~0000389

eureka (reporter)

Sorry caseydk, I cannot diffuse the database because it is not mine, it is that of my company and it contains confidential data

~0000390

eureka (reporter)

a snapshot without data

~0000391

caseydk (administrator)

Thanks, I'll try that this weekend and see if that can do it. :)

~0000427

caseydk (administrator)

Made some tweaks to the sql scripts in r611 to resolve the 'table already exists' errors.

The rest of the errors are allowed/acceptable at present, even if they are annoying.

~0000464

caseydk (administrator)

Closed for release.
+Notes

-Issue History
Date Modified Username Field Change
2009-08-14 07:46 eureka New Issue
2009-08-14 08:32 caseydk Relationship added related to 0000230
2009-08-14 08:33 caseydk Note Added: 0000388
2009-08-14 08:33 caseydk Status new => feedback
2009-08-14 09:02 eureka Note Added: 0000389
2009-08-14 09:14 eureka File Added: dotproject.sql.zip
2009-08-14 09:15 eureka Note Added: 0000390
2009-08-14 09:20 caseydk Note Added: 0000391
2009-09-08 23:38 caseydk Status feedback => resolved
2009-09-08 23:38 caseydk Fixed in Version => 1.1
2009-09-08 23:38 caseydk Resolution open => fixed
2009-09-08 23:38 caseydk Assigned To => caseydk
2009-09-08 23:38 caseydk Note Added: 0000427
2009-09-09 22:44 caseydk Status resolved => closed
2009-09-09 22:44 caseydk Note Added: 0000464
+Issue History