Anonymous Login
2019-10-20 20:11 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000241v1.1 Release (Closed)[All Projects] Generalpublic2009-09-09 22:42
Reportertrevormorse 
Assigned Topedroa 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version1.1 
Target VersionFixed in Version1.1 
Summary0000241: Creating/Editing a task in IE 8 does not work
DescriptionWhen attempting to create a task in IE 8, the software appears to function fine as it returns you to your previous page with no error message, but the task is not created.

When attempting to update a task in IE 8, it appears to function as well, but one of two things happens. Either the task is completely removed from the system or the task is unassociated from its current project. I have experienced both if these, not much fun :-(
Additional InformationIf you run IE 8 in compatibility mode(so it runs as IE 7) things go back to normal.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000408

trevormorse (developer)

This appears to be related to the javascript that is used to combine all the separate forms on the add/edit tasks page before submitting. This becomes apparent under the latest revision that has server side checks for tasks. The start and end dates come back as not being filled in as they are on the second form on the tasks add/edit page.

~0000414

pedroa (administrator)

When adding or editing a task, all the tabs are glued together at submit time with the assistance of some DHTML/Javascript.
If the gluing doesn't work out, only the first fields of the task record are stored, and all the info from the tabs is sent to oblivion.
Restoring these records would require to at least getting the task_owner field populated, or the task becomes phantom (meaning, it is on the DB but the retrieval query misses them because a task should have a owner).
That should be dealt with on another commit.

Since IE 8 behaves more like gecko, we need to check for IEs version number and use the same algorithms as gecko (firefox) and opera.

Files are:
/js/base.js
/js/base_uncompressed.js

Keep in mind that js files may be cached, so make sure that it is the proper version of the base.js file that is running.

Pedro A.

~0000455

caseydk (administrator)

Closed for release.
+Notes

-Issue History
Date Modified Username Field Change
2009-08-27 10:46 trevormorse New Issue
2009-08-31 15:18 trevormorse Note Added: 0000408
2009-09-02 09:40 pedroa Status new => resolved
2009-09-02 09:40 pedroa Resolution open => fixed
2009-09-02 09:40 pedroa Assigned To => pedroa
2009-09-02 09:40 pedroa Note Added: 0000414
2009-09-09 22:42 caseydk Status resolved => closed
2009-09-09 22:42 caseydk Note Added: 0000455
2009-09-09 22:42 caseydk Fixed in Version => 1.1
+Issue History