Anonymous Login
2018-10-17 02:36 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000268v1.2 Release (Closed)[All Projects] Generalpublic2009-12-08 19:08
Reporteregemme 
Assigned Tocaseydk 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version1.2 
Summary0000268: Softcode strings to ignore in file indexation
Description"Get rid of the modules/files/file_index_ignore.php file, make it a System Look Up Value... and make sure it works." --pedroa

ref: http://forums.web2project.net/viewtopic.php?t=993

This way, strings to ignore would be localizable.

TIA
TagsNo tags attached.
Attached Files

-Relationships
child of 0000154new Pending Requests Hard-coded System Parameters 
+Relationships

-Notes

~0000516

pedroa (administrator)

More "interesting" stuff has been added to:
http://web2project.net/forums/viewtopic.php?t=993

Take a look please :)

Pedro A.

~0000544

caseydk (administrator)

This first portion of this one - respecting the file_index_ignore.php file - has been implemented in r698.

Implementing the OS-agnostic indexer is next.

~0000545

caseydk (administrator)

Scratch that... implementing the ignore list as a system lookup value is next.

And then breaking the indexing into a separate step that can be kicked off using the hook_cron functionality independently of the upload step.

~0000546

egemme (reporter)

I have a concern regarding the hook_cron functionality since cron implies the use of Linux. Making indexation asynchronous is a great thing, but please make sure this feature is either optional or can be implemented on Windows.

~0000548

caseydk (administrator)

As Pedro noted on the Forum thread, just because it's in the hook_cron method, it doesn't require cron to call it.

Instead, something that hits the queuescanner.php on a regular basis - iirc, a Windows service can do this - should have you covered. Drupal and a number of other systems do the same thing.

I'm actively working to make sure that we work on Windows approximately as well as we do on Linux... as part of an effort to get added to the Web Platform Installer: http://www.microsoft.com/web/Downloads/platform.aspx

~0000551

caseydk (administrator)

Resolved as described in r701;
+Notes

-Issue History
Date Modified Username Field Change
2009-09-19 05:12 egemme New Issue
2009-09-19 20:25 caseydk Relationship added child of 0000154
2009-09-20 15:39 caseydk Status new => assigned
2009-09-20 15:39 caseydk Assigned To => caseydk
2009-09-21 02:23 pedroa Note Added: 0000516
2009-10-08 22:09 caseydk Note Added: 0000544
2009-10-08 22:13 caseydk Note Added: 0000545
2009-10-09 04:19 egemme Note Added: 0000546
2009-10-09 05:09 caseydk Note Added: 0000548
2009-10-09 21:28 caseydk Status assigned => resolved
2009-10-09 21:28 caseydk Resolution open => fixed
2009-10-09 21:28 caseydk Note Added: 0000551
2009-12-08 19:08 caseydk Status resolved => closed
2009-12-08 19:08 caseydk Fixed in Version => 1.2
+Issue History