Anonymous Login
2019-10-22 19:10 PDT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000299v2.3 Release (Closed)[All Projects] Generalpublic2011-03-24 09:54
ReporterKyle Skrinak 
Assigned Tocaseydk 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version2.3 
Summary0000299: CSS problem on the "a" tag's click event area
DescriptionAlright, though Pedro disagrees, this is bug; what you do with it is up to you. In Safari, (or any WebKit-based browser, I presume) the a tag is split roughly half way, vertically, on the "edit" icon. What this means is that if you were to click on the "edit" icon, you have a 50% of going to the correct data set.

Going to the "Inspect" function of Safari confirms that the a tag block does NOT overlap the icon.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000561

Kyle Skrinak (reporter)

This is a WebKit, (starting at WebKit r50540) not a Safari (4.0.3) issue.

~0000567

caseydk (administrator)

I've dug around on this one... and (not surprisingly) since I can't reproduce this one, I can't begin to debug it usefully. Any suggestions would be appreciated.

~0000570

Kyle Skrinak (reporter)

Again, it's only WebKit (now v50616; available here: http://nightly.webkit.org/) and it is related to the fact that the two css declarations:

table.tbl tr td span
table.tbl tr td span a
are display:inline.

If I redefine this css to display:block; the a tag's active area overlays correctly, but it does ruin the balance of the formatting. I do not have a suitable alternative; although I wonder why do we have a span tag there?

Also, Firefox 3.5, Safari and IE 7. I have filed a bug with Apple and WebKit

~0000573

caseydk (administrator)

Do you have a screencap of what the result looks like?

Could this be resolved (reasonably) if the whole table cell was clickable?

~0000576

Kyle Skrinak (reporter)

It's attached to the initial report. The transparent light-blue overlay shows the anchor tag's click area, which isn't aligned to the icon (as it should be) http://bugs.web2project.net/file_download.php?file_id=63&type=bug

I advise that you can close this, but if there's some evolving css standard that relates to this use of styles, we'll have a record of it as an issue. It might simply be a blip on WebKit's adaptation of css.

~0000577

caseydk (administrator)

Since this is an issue in WebKit's rendering, there's nothing we can or should do about it at this time.

Closed as requested.

~0001444

Kyle Skrinak (reporter)

This bug is confirmed as reported here, with details: http://forums.web2project.net/viewtopic.php?t=2917&highlight=

~0001447

caseydk (administrator)

I've also gotten a handful of browsers to play with and test on and can reproduce it every time in the webkit-based ones. Midori and Chromium are my examples.

~0001491

caseydk (administrator)

Bound the link/span to the image size and location;
Resolved in r1550;
+Notes

-Issue History
Date Modified Username Field Change
2009-11-05 06:04 Kyle Skrinak New Issue
2009-11-05 06:04 Kyle Skrinak File Added: a-tag-overlay-off.png
2009-11-05 06:23 Kyle Skrinak Note Added: 0000561
2009-11-08 20:04 caseydk Project v1.1 Release (Closed) => v1.2 Release (Closed)
2009-11-08 20:30 caseydk Note Added: 0000567
2009-11-08 20:30 caseydk Project v1.2 Release (Closed) => Pending Requests
2009-11-09 02:50 Kyle Skrinak Note Added: 0000570
2009-11-09 21:26 caseydk Note Added: 0000573
2009-11-10 02:36 Kyle Skrinak Note Added: 0000576
2009-11-10 05:15 caseydk Status new => closed
2009-11-10 05:15 caseydk Note Added: 0000577
2009-11-10 05:15 caseydk Resolution open => won't fix
2010-12-16 17:08 Kyle Skrinak Note Added: 0001444
2010-12-16 17:08 Kyle Skrinak Status closed => feedback
2010-12-16 17:08 Kyle Skrinak Resolution won't fix => reopened
2010-12-18 19:50 caseydk Note Added: 0001447
2010-12-18 19:51 caseydk Priority normal => high
2010-12-18 19:51 caseydk Severity minor => major
2010-12-22 23:05 caseydk Project Pending Requests => v2.3 Release (Closed)
2010-12-22 23:06 caseydk Note Added: 0001491
2010-12-22 23:06 caseydk Status feedback => resolved
2010-12-22 23:06 caseydk Resolution reopened => fixed
2010-12-22 23:06 caseydk Assigned To => caseydk
2011-03-24 09:53 caseydk Fixed in Version => 2.3
2011-03-24 09:54 caseydk Status resolved => closed
+Issue History